summary refs log tree commit diff
path: root/gnu/packages/firmware.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/firmware.scm')
-rw-r--r--gnu/packages/firmware.scm33
1 files changed, 22 insertions, 11 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 3dcc882e0c..ff5afbcbe1 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -489,7 +489,7 @@ provide OpenFirmware functionality on top of an already running system.")
 (define* (make-opensbi-package platform name #:optional (arch "riscv64"))
   (package
     (name name)
-    (version "1.3")
+    (version "1.3.1")
     (source
      (origin
        (method git-fetch)
@@ -498,7 +498,7 @@ provide OpenFirmware functionality on top of an already running system.")
              (commit (string-append "v" version))))
        (file-name (git-file-name "opensbi" version))
        (sha256
-        (base32 "0shri9jlhi2g464l05vrkzr6v754m868rr4136kq2b86amypmg8f"))))
+        (base32 "01pr7fyg3gcb5pj6d48w2an3m4mfjs9b398x31drqxwqcaz0zn94"))))
     (build-system gnu-build-system)
     (native-inputs
      (append
@@ -518,11 +518,6 @@ provide OpenFirmware functionality on top of an already running system.")
                                 `("CC=gcc"))
                           "FW_PAYLOAD=n"
                           "V=1")
-       ;; Direct __asm__ is used with fence.i instructions, which are not
-       ;; available in the generic riscv ISA.  We need a micro-arch with
-       ;; support for it, and rv64g is the official ISA with support for
-       ;; fence.i.
-       #:configure-flags (list "-march=rv64g")
        #:phases
        (modify-phases %standard-phases
          (delete 'configure)
@@ -575,7 +570,7 @@ executing in M-mode.")
 (define-public seabios
   (package
     (name "seabios")
-    (version "1.16.1")
+    (version "1.16.2")
     (source
      (origin
        (method git-fetch)
@@ -584,7 +579,7 @@ executing in M-mode.")
              (commit (string-append "rel-" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0gph1hf70jjpx55qc0lzx2yghkipg9dnsin07i4jajk0p1jpd2d0"))
+        (base32 "1mal2zqn4ppxdjxddrxcphm6z9n8n4rw97xl2hldd7spw57nwq97"))
        (modules '((guix build utils)))
        (snippet
         #~(begin
@@ -1025,7 +1020,7 @@ Virtual Machines.  OVMF contains a sample UEFI firmware for QEMU and KVM.")
                                        (gnu-triplet->nix-system triplet))))))
     (package
       (name (string-append "arm-trusted-firmware-" platform))
-      (version "2.8")
+      (version "2.9")
       (source
        (origin
          (method git-fetch)
@@ -1036,7 +1031,7 @@ Virtual Machines.  OVMF contains a sample UEFI firmware for QEMU and KVM.")
          (file-name (git-file-name "arm-trusted-firmware" version))
          (sha256
           (base32
-           "0grq3fgxi9xhcljnhwlxjvdghyz15gaq50raw41xy4lm8rkmnzp3"))
+           "16fjbn1zck0d8b554h8lk1svqqn0zlawvrlkjxry9l71s9h4vd0p"))
          (snippet
           #~(begin
               (use-modules (guix build utils))
@@ -1104,6 +1099,22 @@ such as:
   (let ((base (make-arm-trusted-firmware "imx8mq")))
     (package
       (inherit base)
+      ;; Newer versions do not build and are essentially not supported
+      ;; upstream.
+      ;; XXX: explore using NXP maintained branch
+      ;; https://github.com/nxp-imx/imx-atf
+      (version "2.8")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               ;; There are only GitHub generated release snapshots.
+               (url "https://git.trustedfirmware.org/TF-A/trusted-firmware-a.git/")
+               (commit (string-append "v" version))))
+         (file-name (git-file-name "arm-trusted-firmware" version))
+         (sha256
+          (base32
+           "0grq3fgxi9xhcljnhwlxjvdghyz15gaq50raw41xy4lm8rkmnzp3"))))
       (arguments
        (substitute-keyword-arguments (package-arguments base)
          ((#:make-flags flags ''())