summary refs log tree commit diff
path: root/gnu/packages/firmware.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/firmware.scm')
-rw-r--r--gnu/packages/firmware.scm41
1 files changed, 21 insertions, 20 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 696814cc71..e9bb3ed450 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -2,7 +2,7 @@
 ;;; Copyright © 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2017 David Craven <david@craven.ch>
-;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2018, 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Vagrant Cascadian <vagrant@debian.org>
 ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
@@ -259,19 +259,11 @@ driver.")
                          help2man
                          gettext-minimal))
     (inputs (list bash-completion
-                  glib
                   libgudev
                   libxmlb
-                  gusb
                   sqlite
-                  libarchive
-                  libjcat
-                  json-glib
-                  curl
                   polkit
                   eudev
-                  gcab
-                  gnutls
                   libelf
                   tpm2-tss
                   cairo
@@ -281,6 +273,15 @@ driver.")
                   mingw-w64-tools
                   libsmbios
                   gnu-efi))
+    ;; In Requires of fwupd*.pc.
+    (propagated-inputs (list curl
+                             gcab
+                             glib
+                             gnutls
+                             gusb
+                             json-glib
+                             libarchive
+                             libjcat))
     (home-page "https://fwupd.org/")
     (synopsis "Daemon to allow session software to update firmware")
     (description "This package aims to make updating firmware on GNU/Linux
@@ -644,7 +645,7 @@ Virtual Machines.  OVMF contains a sample UEFI firmware for QEMU and KVM.")
 (define* (make-arm-trusted-firmware platform #:optional (arch "aarch64"))
   (package
     (name (string-append "arm-trusted-firmware-" platform))
-    (version "2.6")
+    (version "2.8")
     (source
       (origin
         (method git-fetch)
@@ -655,27 +656,27 @@ Virtual Machines.  OVMF contains a sample UEFI firmware for QEMU and KVM.")
         (file-name (git-file-name "arm-trusted-firmware" version))
        (sha256
         (base32
-         "1j0rn33pwgmksqliwf2npm2px84qmbyma9iq8zpllwfc7dsl6gx9"))))
+         "0grq3fgxi9xhcljnhwlxjvdghyz15gaq50raw41xy4lm8rkmnzp3"))
+       (snippet
+        #~(begin
+            (use-modules (guix build utils))
+            ;; Remove binary blobs which do not contain source or proper license.
+            (for-each (lambda (file)
+                        (delete-file file))
+                      (find-files "." "\\.bin$"))))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
          (delete 'configure) ; no configure script
-         ;; Remove binary blobs which do not contain source or proper license.
-         (add-after 'unpack 'remove-binary-blobs
-           (lambda _
-             (for-each (lambda (file)
-                         (delete-file file))
-                       (find-files "." ".*\\.bin$"))))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out"))
-                   (bin (find-files "." ".*\\.(bin|elf)$")))
+                   (bin (find-files "." "\\.(bin|elf)$")))
                (for-each
                  (lambda (file)
                    (install-file file out))
-                 bin))
-             #t)))
+                 bin)))))
        #:make-flags (list (string-append "PLAT=" ,platform)
                           ,@(if (and (not (string-prefix? "aarch64"
                                                           (%current-system)))