summary refs log tree commit diff
path: root/gnu/packages/firmware.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/firmware.scm')
-rw-r--r--gnu/packages/firmware.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index a876aa727a..956ece5d6d 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -410,7 +410,8 @@ utilites used to process FCODE, OpenFirmware's byte code, consisting of:
               (file-name (git-file-name "openbios" version))
               (sha256
                (base32
-                "1xp1b6xgx40i0j3a5y3id0d1p8vdvapai8szganxg3zrvj53fh0n"))))
+                "1xp1b6xgx40i0j3a5y3id0d1p8vdvapai8szganxg3zrvj53fh0n"))
+              (patches (search-patches "openbios-aarch64-riscv64-support.patch"))))
     (build-system gnu-build-system)
     (arguments
      (list #:tests? #f                  ;no tests
@@ -422,8 +423,9 @@ utilites used to process FCODE, OpenFirmware's byte code, consisting of:
                      (("TZ=UTC date \\+")
                       "TZ=UTC date --date=@1 +"))))
                (replace 'configure
-                 (lambda _
-                   (invoke "./config/scripts/switch-arch" #$arch)))
+                 (lambda* (#:key (configure-flags #~'()) #:allow-other-keys)
+                   (apply invoke "./config/scripts/switch-arch" #$arch
+                          configure-flags)))
                (replace 'install
                  (lambda _
                    (let ((build-target
@@ -456,11 +458,6 @@ provide OpenFirmware functionality on top of an already running system.")
       (inherit base)
       (arguments
        (substitute-keyword-arguments (package-arguments base)
-         ((#:system system (%current-system))
-          (if (string-prefix? "aarch64-linux" (or (%current-system)
-                                                  (%current-target-system)))
-            "armhf-linux"
-            system))
          ;; No need to cross-compile, package produces reproducible firmware.
          ((#:target _ #f) #f)
          ((#:phases phases)