summary refs log tree commit diff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 13699cdfce..33935c5699 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -982,11 +982,15 @@ display all Unicode symbols.")
      (list
       #:phases
       #~(modify-phases %standard-phases
-          (add-after 'unpack 'remove-unsupported
+          (add-after 'unpack 'enter-font-directory
+            (lambda _
+              ;; Note this ensures the correct license file is installed.
+              (chdir "fonts")))
+          (add-after 'enter-font-directory 'remove-unsupported
             (lambda* _
-              (delete-file "fonts/NotoColorEmoji_WindowsCompatible.ttf")
-              (delete-file "fonts/Noto-COLRv1-noflags.ttf")
-              (delete-file "fonts/Noto-COLRv1.ttf"))))))
+              (delete-file "NotoColorEmoji_WindowsCompatible.ttf")
+              (delete-file "Noto-COLRv1-noflags.ttf")
+              (delete-file "Noto-COLRv1.ttf"))))))
     (home-page "https://fonts.google.com/noto/specimen/Noto+Color+Emoji")
     (synopsis "Font for rendering color emoji characters")
     (description