summary refs log tree commit diff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 3806d78b1e..902472546e 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -2,7 +2,7 @@
 ;;; Copyright © 2013, 2014, 2015 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2014, 2016 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016, 2017, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2020, 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017 Rene Saavedra <rennes@openmailbox.org>
 ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2017 Nikita <nikita@n0.is>
@@ -84,14 +84,14 @@
 (define-public freetype
   (package
    (name "freetype")
-   (version "2.10.4")
+   (version "2.12.1")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "mirror://savannah/freetype/freetype-"
                           version ".tar.xz"))
       (sha256
-       (base32 "112pyy215chg7f7fmp2l9374chhhpihbh8wgpj5nj6avj3c59a46"))))
+       (base32 "0zqsqi092sxzvqc31b23n8ww9lcjgy8vz01g576z0k6caw0z4rj7"))))
    (build-system gnu-build-system)
    (arguments
     ;; The use of "freetype-config" is deprecated, but other packages still
@@ -111,7 +111,7 @@ It supports both bitmap and scalable formats, including TrueType, OpenType,
 Type1, CID, CFF, Windows FON/FNT, X11 PCF, and others.  It supports high-speed
 anti-aliased glyph bitmap generation with 256 gray levels.")
    (license license:freetype)           ; some files have other licenses
-   (home-page "https://www.freetype.org/")))
+   (home-page "https://freetype.org/")))
 
 (define-public opentype-sanitizer
   (package
@@ -260,7 +260,7 @@ them as it goes.")
            python-booleanoperations
            python-defcon
            python-fontmath
-           python-fonttools-next
+           python-fonttools
            python-lxml
            python-tqdm
            python-ufonormalizer
@@ -455,7 +455,7 @@ converts any cubic curves to quadratic.  The most useful function is probably
            python-compreffor
            python-cu2qu
            python-defcon
-           python-fonttools-next
+           python-fonttools
            python-skia-pathops
            python-ufolib2))
     (home-page "https://github.com/googlefonts/ufo2ft")
@@ -623,7 +623,7 @@ process.  FontParts is the successor of RoboFab.")
            python-xmldiff))
     (propagated-inputs
      (list python-defcon
-           python-fonttools-next
+           python-fonttools
            python-openstep-plist
            python-ufolib2
            python-ufo2ft
@@ -781,7 +781,7 @@ suite of the @code{psautohint} package.")
             (lambda* (#:key tests? #:allow-other-keys)
               (when tests?
                 (invoke "pytest" "-vv")))))))
-    (propagated-inputs (list python-fonttools-next))
+    (propagated-inputs (list python-fonttools))
     (native-inputs
      (list psautohint-font-data
            python-fs
@@ -1144,14 +1144,14 @@ Font Format (WOFF).")
   (hidden-package
    (package
      (name "fontconfig-minimal")
-     (version "2.13.94")
+     (version "2.14.0")
      (source (origin
                (method url-fetch)
                (uri (string-append
                      "https://www.freedesktop.org/software/"
                      "fontconfig/release/fontconfig-" version ".tar.xz"))
                (sha256 (base32
-                        "0g004r0bkkqz00mpm3svnnxn7d83158q0yb9ggxryizxfg5m5w55"))
+                        "1b4v1r94ri44p4a3kbwd38ig5jgdgcfgwdfm6fqzvfvlki6bignw"))
                (patches (search-patches "fontconfig-cache-ignore-mtime.patch"))))
      (build-system gnu-build-system)
      ;; In Requires or Requires.private of fontconfig.pc.
@@ -1622,7 +1622,7 @@ generate bitmaps.")
     (propagated-inputs
      (list python-attrs
            python-cattrs
-           python-fonttools-next))
+           python-fonttools))
     (home-page "https://github.com/daltonmaag/statmake")
     (synopsis "Apply OpenType STAT information to a variable font")
     (description