summary refs log tree commit diff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm37
1 files changed, 30 insertions, 7 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index cacda2ed04..7ede94717c 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -327,6 +327,7 @@ Font Format (WOFF).")
             (patches (search-patches "fontconfig-hurd-path-max.patch"))
             (sha256 (base32
                      "0hb700a68kk0ip51wdlnjjc682kvlrmb6q920mzajykdk0mdsmgn"))))
+   (outputs '("out" "doc"))
    (build-system gnu-build-system)
    ;; In Requires or Requires.private of fontconfig.pc.
    (propagated-inputs `(("expat" ,expat)
@@ -357,11 +358,33 @@ Font Format (WOFF).")
       #:phases
       (modify-phases %standard-phases
         (replace 'install
-                 (lambda _
-                   ;; Don't try to create /var/cache/fontconfig.
-                   (invoke "make" "install"
-                           "fc_cachedir=$(TMPDIR)"
-                           "RUN_FC_CACHE_TEST=false"))))))
+          (lambda _
+            ;; Don't try to create /var/cache/fontconfig.
+            (invoke "make" "install"
+                    "fc_cachedir=$(TMPDIR)"
+                    "RUN_FC_CACHE_TEST=false")))
+        (add-after 'install 'move-man-sections
+          (lambda* (#:key outputs #:allow-other-keys)
+            ;; Move share/man/man{3,5} to the "doc" output.  Leave "man1" in
+            ;; "out" for convenience.
+            (let ((out (assoc-ref outputs "out"))
+                  (doc (assoc-ref outputs "doc")))
+              (for-each (lambda (section)
+                          (let ((source (string-append out "/share/man/"
+                                                       section))
+                                (target (string-append doc "/share/man/"
+                                                       section)))
+                            (copy-recursively source target)
+                            (delete-file-recursively source)))
+                        '("man3" "man5"))
+              #t)))
+        (add-after 'install 'remove-pdf-files
+          (lambda* (#:key outputs #:allow-other-keys)
+            ;; By default PDF versions of the user and development manuals are
+            ;; installs but they bring nothing useful.  Remove them.
+            (let ((doc (assoc-ref outputs "doc")))
+              (for-each delete-file (find-files doc "\\.pdf$"))
+              #t))))))
    (synopsis "Library for configuring and customizing font access")
    (description
     "Fontconfig can discover new fonts when installed automatically;
@@ -420,14 +443,14 @@ X11-system or any other graphical user interface.")
 (define-public teckit
   (package
     (name "teckit")
-    (version "2.5.9")                   ;signed by key 0xC9183BEA0288CDEE
+    (version "2.5.10")                  ; signed by key 0xC9183BEA0288CDEE
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://github.com/silnrsi/teckit/releases/"
                            "download/v" version "/teckit-" version ".tar.gz"))
        (sha256
-        (base32 "0gbxyip4wdibirdg2pvzayzyy927vxyd6dfyfiflx8zg88qzn8v8"))))
+        (base32 "12qnf8nhxyr4d5pc01s3vc6h726506957an4vvmmfz633cqi5796"))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags '("--disable-static")))