summary refs log tree commit diff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 40d41350ac..fdb046a5f3 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -215,12 +215,13 @@ application-centers for distributions.")
        (sha256
         (base32 "1sd8syldyq6bphfdm129s3gq554vfv7vh1vcwzk48gjryf101awk"))
        (patches
-        (search-patches "farstream-make.patch"))))
+        (search-patches
+         "farstream-gupnp.patch"        ;for test 'transmitter/rawudp'
+         "farstream-make.patch"))))
     (build-system glib-or-gtk-build-system)
     (outputs '("out" "doc"))
     (arguments
-     `(#:tests? #f ; https://gitlab.freedesktop.org/farstream/farstream/-/issues/18
-       #:configure-flags
+     `(#:configure-flags
        (list
         "--enable-gtk-doc"
         "--enable-glib-asserts"
@@ -236,6 +237,15 @@ application-centers for distributions.")
               (assoc-ref %build-inputs "common")
               "common")
              #t))
+         (add-after 'unpack 'disable-timeout-tests
+           (lambda _
+             (substitute* "tests/check/Makefile.am"
+               ;; This test timeouts despite changing
+               ;; the value of 'CK_DEFAULT_TIMEOUT' to 600,
+               ;; as per %common-gstreamer-phases.
+               ;; Reported to upstream:
+               ;; https://gitlab.freedesktop.org/farstream/farstream/-/issues/20
+               (("[ \t]*transmitter/nice.*$") ""))))
          (add-after 'unpack 'patch-docbook-xml
            (lambda* (#:key inputs #:allow-other-keys)
              (with-directory-excursion "docs"