summary refs log tree commit diff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm62
1 files changed, 47 insertions, 15 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 818d9966dd..55bde8e705 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -5,7 +5,7 @@
 ;;; Copyright © 2015-2017, 2019, 2021 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015, 2017, 2018, 2019, 2021 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
-;;; Copyright © 2016, 2017, 2019, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2019, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
 ;;; Copyright © 2017 Nikita <nikita@n0.is>
 ;;; Copyright © 2017, 2018 Mark H Weaver <mhw@netris.org>
@@ -585,11 +585,15 @@ the freedesktop.org XDG Base Directory specification.")
                  (sysconf (string-append out "/etc"))
                  (libexec (string-append out "/libexec/elogind"))
                  (dbuspolicy (string-append out "/etc/dbus-1/system.d"))
-                 (kexec-tools #$(this-package-input "kexec-tools"))
+                 #$@(if (not (target-riscv64?))
+                      #~((kexec-tools #$(this-package-input "kexec-tools")))
+                      #~())
                  (shadow #$(this-package-input "shadow"))
                  (shepherd #$(this-package-input "shepherd"))
                  (halt-path (string-append shepherd "/sbin/halt"))
-                 (kexec-path (string-append kexec-tools "/sbin/kexec"))
+                 #$@(if (not (target-riscv64?))
+                      #~((kexec-path (string-append kexec-tools "/sbin/kexec")))
+                      #~())
                  (nologin-path (string-append shadow "/sbin/nologin"))
                  (poweroff-path (string-append shepherd "/sbin/shutdown"))
                  (reboot-path (string-append shepherd "/sbin/reboot")))
@@ -601,7 +605,9 @@ the freedesktop.org XDG Base Directory specification.")
              (string-append "-Dc_link_args=-Wl,-rpath=" libexec)
              (string-append "-Dcpp_link_args=-Wl,-rpath=" libexec)
              (string-append "-Dhalt-path=" halt-path)
-             (string-append "-Dkexec-path=" kexec-path)
+             #$@(if (not (target-riscv64?))
+                  #~((string-append "-Dkexec-path=" kexec-path))
+                  #~())
              (string-append "-Dpoweroff-path=" poweroff-path)
              (string-append "-Dreboot-path=" reboot-path)
              (string-append "-Dnologin-path=" nologin-path)
@@ -675,15 +681,18 @@ the freedesktop.org XDG Base Directory specification.")
        ("python" ,python)
        ("xsltproc" ,libxslt)))
     (inputs
-     (list kexec-tools
-           linux-pam
-           libcap
-           shadow ;for 'nologin'
-           shepherd ;for 'halt' and 'reboot', invoked
-           ;when pressing the power button
-           dbus
-           eudev
-           acl))           ;to add individual users to ACLs on /dev nodes
+     (append
+       (if (not (target-riscv64?))
+         (list kexec-tools)
+         '())
+       (list linux-pam
+             libcap
+             shadow         ; for 'nologin'
+             shepherd       ; for 'halt' and 'reboot', invoked
+                            ; when pressing the power button
+             dbus
+             eudev
+             acl)))         ; to add individual users to ACLs on /dev nodes
     (home-page "https://github.com/elogind/elogind")
     (synopsis "User, seat, and session management service")
     (description "Elogind is the systemd project's \"logind\" service,
@@ -1046,7 +1055,7 @@ protocol either in Wayland core, or some other protocol in wayland-protocols.")
 (define-public waylandpp
   (package
     (name "waylandpp")
-    (version "0.2.8")
+    (version "0.2.9")
     (home-page "https://github.com/NilsBrause/waylandpp")
     (source (origin
               (method git-fetch)
@@ -1054,7 +1063,7 @@ protocol either in Wayland core, or some other protocol in wayland-protocols.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1kxiqab48p0n97pwg8c2zx56wqq32m3rcq7qd2pjj33ipcanb3qq"))))
+                "0z4m30r609as3kpcgipivddr98y7h529r7ldn9ba4snhk341mfvk"))))
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f))                    ; no tests
@@ -1201,6 +1210,29 @@ sent to a Wayland window, such as key presses.  It is analogous to the X11 tool
 XEv.")
     (license license:expat)))
 
+(define-public wtype
+  (package
+    (name "wtype")
+    (version "0.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/atx/wtype.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0bpix92vzip9vlhzihj3k8h9flrlna231x3y8ah7p4965l177yjd"))))
+    (build-system meson-build-system)
+    (native-inputs
+     (list pkg-config wayland libxkbcommon))
+    (synopsis "Xdotool type for Wayland")
+    (description "Wtype lets you simulate keyboard input and mouse activity,
+move and resize windows, etc.")
+    (home-page "https://github.com/atx/wtype")
+    ;; MIT License
+    (license license:expat)))
+
 (define-public exempi
   (package
     (name "exempi")