summary refs log tree commit diff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 78983cd991..b67c4e51d2 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1244,8 +1244,7 @@ developed mainly for Ren'py.")
      `(("python2-future" ,python2-future)
        ("python2-pygame" ,python2-pygame-sdl2)))
     (native-inputs
-     `(("gcc" ,gcc-8) ; for const variables as initializer elements
-       ("python2-cython" ,python2-cython)
+     `(("python2-cython" ,python2-cython)
        ("xdg-utils" ,xdg-utils)))
     (home-page "https://www.renpy.org/")
     (synopsis "Ren'py python module")
@@ -1425,7 +1424,7 @@ if __name__ == \"__main__\":
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (wrap-program (string-append (assoc-ref outputs "out")
                                           "/bin/renpy")
-               `("PYTHONPATH" = (,(getenv "PYTHONPATH"))))
+               `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH"))))
              #t)))))
     (inputs
      `(("python2-tkinter" ,python-2 "tk")