summary refs log tree commit diff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index b57f46c69e..49fe467252 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1353,20 +1353,21 @@ that parenthetically inclined game developers need to make 2D (and eventually
     (arguments
      '(#:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'patch-configure-for-x86-64
+         (add-after 'unpack 'patch-configure-to-use-openssl
            (lambda* (#:key outputs #:allow-other-keys)
              (chdir "core")
              (delete-file "configure")
              (substitute* "configure.in"
                (("i\\*86\\)")
-                "x86_64)
+                "*)
                 COMMON_CFLAGS=\"$COMMON_CFLAGS -DUSE_OPENSSL\"
                 COMMON_LDFLAGS=\"$COMMON_LDFLAGS\"
                 LIBSSL=\"crypto\"
                 USE_OPENSSL=yes
                 ;;
 
-            i*86)")))))))
+            i*86)"))
+               #t)))))
     (inputs `(("openssl" ,openssl)
               ("zlib" ,zlib)))
     (native-inputs `(("pkg-config" ,pkg-config)