summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm67
1 files changed, 51 insertions, 16 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 9ff08e5e74..f150c33e83 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -938,6 +938,41 @@ original rogue game found on 4.2BSD.")
     (home-page "https://github.com/Davidslv/rogue")
     (license license:bsd-3)))
 
+(define-public sgt-puzzles
+  (let ((commit "80aac3104096aee4057b675c53ece8e60793aa90")
+        (revision "0"))
+    (package
+      (name "sgt-puzzles")
+      (version (git-version "20240302" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://git.tartarus.org/simon/puzzles.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0z4clv0xi98q28riz323ppn165cm62gj1c6h3xdd2sym4v8gy65z"))))
+      (build-system cmake-build-system)
+      (arguments
+       (list
+        #:tests? #f                     ;No tests.
+        #:configure-flags #~(list "-DNAME_PREFIX=sgt-")
+        #:phases
+        #~(modify-phases %standard-phases
+            (add-after 'unpack 'set-xdg-open-path
+              (lambda* (#:key inputs #:allow-other-keys)
+                (substitute* "gtk.c"
+                  (("(#define HELP_BROWSER_PATH).+" all define)
+                   (format #f "~a ~s~%" define
+                           (search-input-file inputs "/bin/xdg-open")))))))))
+      (inputs (list gtk+ xdg-utils))
+      (native-inputs (list pkg-config perl imagemagick halibut))
+      (home-page "https://www.chiark.greenend.org.uk/~sgtatham/puzzles/")
+      (synopsis "Simon Tatham's portable puzzle collection")
+      (description "Simon Tatham's Portable Puzzle Collection contains a number of
+popular puzzle games for one player.")
+      (license license:expat))))
 
 (define-public bzflag
   (package
@@ -2130,14 +2165,14 @@ It is similar to standard chess but this variant is far more complicated.")
 (define-public ltris
   (package
     (name "ltris")
-    (version "1.2.6")
+    (version "1.3")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://sourceforge/lgames/ltris/"
                            "ltris-" version ".tar.gz"))
        (sha256
-        (base32 "1xj65kn815x2hq1ynzjyc90dj178xwa2xvx7jx99qf60ahaf4g62"))))
+        (base32 "144zvnnky79z5ychyyb2wsp7h2pcbl50fbzd9w9dvxkw6adz4yip"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases
@@ -4676,7 +4711,7 @@ on the screen and keyboard to display letters.")
 (define-public manaplus
   (package
     (name "manaplus")
-    (version "1.9.3.23")
+    (version "2.1.3.17")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -4684,18 +4719,15 @@ on the screen and keyboard to display letters.")
                     version "/manaplus-" version ".tar.xz"))
               (sha256
                (base32
-                "1ky182p4svwdqm6cf7jbns85hidkhkhq4s17cs2p381f0klapfjz"))))
+                "0ggswsa3xq7lss3j4k7fyzn56sw7hlrwk744i3d9w0n4932nmlg8"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:configure-flags
-       (list (string-append "CPPFLAGS=-I"
-                            (assoc-ref %build-inputs "sdl-union")
-                            "/include/SDL"))))
+     (list #:configure-flags #~'("--with-sdl2")))
     (native-inputs
      (list pkg-config))
     (inputs
      (list glu curl libxml2 mesa
-           (sdl-union)))
+           sdl2 sdl2-image sdl2-mixer sdl2-net sdl2-ttf))
     (home-page "https://manaplus.org")
     (synopsis "Client for 'The Mana World' and similar games")
     (description
@@ -7426,7 +7458,7 @@ at their peak of economic growth and military prowess.
 (define-public open-adventure
   (package
     (name "open-adventure")
-    (version "1.16")
+    (version "1.18")
     (source
      (origin
        (method git-fetch)
@@ -7435,7 +7467,7 @@ at their peak of economic growth and military prowess.
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0spciwqcyldalzdd813zwigbldcnyaxi7kfslq1yp0fg4c4a10aa"))))
+        (base32 "1zl72lsp443aryzmwzh5w4j439jgf5njvh9xig6vjvmzhfcjkk9q"))))
     (build-system gnu-build-system)
     (arguments
      (list
@@ -7464,10 +7496,13 @@ at their peak of economic growth and military prowess.
                 (install-file "advent.6" man)))))))
     (native-inputs
      (list asciidoc
+           cppcheck
            libedit
            pkg-config
+           python-pylint
            python-pyyaml
-           python-wrapper))
+           python-wrapper
+           ruby-asciidoctor))
     (home-page "https://gitlab.com/esr/open-adventure")
     (synopsis "Colossal Cave Adventure")
     (description
@@ -8452,7 +8487,7 @@ ncurses for text display.")
 (define-public naev
   (package
     (name "naev")
-    (version "0.10.4")
+    (version "0.11.4")
     (source
      (origin
        (method git-fetch)
@@ -8462,7 +8497,7 @@ ncurses for text display.")
              (recursive? #t))) ; for game data
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0lg8cmzdzzpmqgmh9a1v190vv4d15hwa0inyzdwsq5x8lyc13hyr"))))
+        (base32 "1gd7jgb996fgnlrlqkfyx416g1kd458vik3nviazwwj83ksafaqb"))))
     (build-system meson-build-system)
     (arguments
      ;; XXX: Do not add debugging symbols, which cause the build to fail.
@@ -11379,7 +11414,7 @@ play; it will look for them at @file{~/.local/share/fheroes2} folder.")
 (define-public vcmi
   (package
     (name "vcmi")
-    (version "1.4.2")
+    (version "1.4.5")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -11388,7 +11423,7 @@ play; it will look for them at @file{~/.local/share/fheroes2} folder.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "039d9dvb2i4y1fj6q5py34r17fwb5jqxkjcg7j57asjk4w9b7i8b"))
+                "1z4vy3drj6dra8rb243pyryr61jnlw3l7yxsxwl9rddv8cdk69lz"))
               (patches (search-patches "vcmi-disable-privacy-breach.patch"))))
     (build-system cmake-build-system)
     (arguments