summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm48
1 files changed, 44 insertions, 4 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 0142fc8ed2..728f763806 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -793,6 +793,46 @@ role, and your gender.")
       (license:fsdg-compatible
         "https://nethack.org/common/license.html"))))
 
+(define-public pipewalker
+  (package
+    (name "pipewalker")
+    (version "0.9.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://downloads.sourceforge.net/pipewalker/"
+                           name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1x46wgk0s55562pd96cxagxkn6wpgglq779f9b64ff1k3xzp3myn"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags
+       (list (string-append "--docdir=" (assoc-ref %outputs "out")
+                            "/share/doc/" ,name "-" ,version))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'configure 'patch-docdir
+           ;; Makefile.in ignores configure's ‘--docdir=...’ option.  Fix that.
+           (lambda _
+             (substitute* "Makefile"
+               (("(pkgdocdatadir = ).*" _ assignment)
+                (string-append assignment "$(docdir)\n")))
+             #t)))))
+    (inputs
+     `(("libpng" ,libpng)
+       ("mesa" ,mesa)
+       ("sdl" ,sdl)))
+    (home-page "http://pipewalker.sourceforge.net/")
+    (synopsis "Logical tile puzzle")
+    (description
+     "PipeWalker is a simple puzzle game with many diffent themes: connect all
+computers to one network server, bring water from a source to the taps, etc.
+The underlying mechanism is always the same: you must turn each tile in the
+grid in the right direction to combine all components into a single circuit.
+Every puzzle has a complete solution, although there may be more than one.")
+    (license license:gpl3+)))
+
 (define-public prboom-plus
   (package
    (name "prboom-plus")
@@ -2430,7 +2470,7 @@ Transport Tycoon Deluxe.")
 (define openrct2-objects
   (package
    (name "openrct2-objects")
-   (version "1.0.2")
+   (version "1.0.6")
    (source
     (origin
      (method url-fetch)
@@ -2439,7 +2479,7 @@ Transport Tycoon Deluxe.")
      (file-name (string-append name "-" version ".zip"))
      (sha256
       (base32
-       "1z92afhbv13j1ig6fz0x8w9vdmfchssv16vwwhb0vj40pn1g1rwy"))))
+       "00kfy95zx6g4ldr6br5p7bwkwfx6pw9v78fd3rvghjnwyvf5fhki"))))
    (build-system trivial-build-system)
    (native-inputs
     `(("bash" ,bash)
@@ -2471,7 +2511,7 @@ Transport Tycoon Deluxe.")
 (define-public openrct2
   (package
     (name "openrct2")
-    (version "0.2.0")
+    (version "0.2.1")
     (source
      (origin
        (method url-fetch)
@@ -2479,7 +2519,7 @@ Transport Tycoon Deluxe.")
                            version ".tar.gz"))
        (sha256
         (base32
-         "1yrbjra27n2xxb1x47v962lc3qi8gwm5ws4f97952nvn533zrwxz"))
+         "1fxzk037xphpyk7vv5jfrcz739zrj86p43pnf5gjjv9rjxwv7m8f"))
        (file-name (string-append name "-" version ".tar.gz"))))
     (build-system cmake-build-system)
     (arguments