summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a072564d46..3d825cbe61 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1890,7 +1890,15 @@ match, cannon keep, and grave-itation pit.")
               (modules '((guix build utils)))
               (snippet
                '(begin
-                  (delete-file-recursively "lib") #t))))
+                  ;; Mimic upstream commit 706b6aad06, for compatibility with
+                  ;; newer jsoncpp.  Remove this for > 5.1.0.
+                  (substitute* "cmake/Modules/FindJson.cmake"
+                    (("features\\.h")
+                     "allocator.h"))
+
+                  ;; Delete bundled libraries.
+                  (delete-file-recursively "lib")
+                  #t))))
     (build-system cmake-build-system)
     (arguments
      '(#:configure-flags