summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm69
1 files changed, 16 insertions, 53 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c8d671bbdc..066e2c8cf3 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -24,7 +24,7 @@
 ;;; Copyright © 2016 Steve Webber <webber.sl@gmail.com>
 ;;; Copyright © 2017 Adonay "adfeno" Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <adfeno@hyperbola.info>
 ;;; Copyright © 2017, 2018 Arun Isaac <arunisaac@systemreboot.net>
-;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2017, 2019 nee <nee-git@hidamari.blue>
 ;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
 ;;; Copyright © 2017, 2019 Marius Bakke <mbakke@fastmail.com>
@@ -37,7 +37,7 @@
 ;;; Copyright © 2018 Benjamin Slade <slade@jnanam.net>
 ;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
 ;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
-;;; Copyright © 2019 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2019, 2020 Oleg Pykhalov <go.wigust@gmail.com>
 ;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2019 Jesse Gibbons <jgibbons2357+guix@gmail.com>
@@ -946,7 +946,7 @@ watch your CPU playing while enjoying a cup of tea!")
 (define-public nethack
   (package
     (name "nethack")
-    (version "3.6.2")
+    (version "3.6.4")
     (source
       (origin
         (method url-fetch)
@@ -954,7 +954,7 @@ watch your CPU playing while enjoying a cup of tea!")
          (string-append "https://www.nethack.org/download/" version "/nethack-"
                         (string-join (string-split version #\.) "") "-src.tgz"))
         (sha256
-          (base32 "07fvkm3v11a4pjrq2f66vjslljsvk6raal53skn4gqsfdbd0ml7v"))))
+          (base32 "0ndxgnsprwgjnk0qb24iljkpijnfncgvfb3h3zb129h3cs2anc85"))))
     (inputs
       `(("ncurses" ,ncurses)
         ("bison" ,bison)
@@ -4144,7 +4144,7 @@ for Un*x systems with X11.")
 (define-public freeciv
   (package
    (name "freeciv")
-   (version "2.6.0")
+   (version "2.6.1")
    (source
     (origin
      (method url-fetch)
@@ -4156,8 +4156,7 @@ for Un*x systems with X11.")
                   (version-major+minor version) "/" version
                   "/freeciv-" version ".tar.bz2")))
      (sha256
-      (base32
-       "16f9wsnn7073s6chzbm3819swd0iw019p9nrzr3diiynk28kj83w"))))
+      (base32 "1qmrhrwm0ryvsh1zsxcxj128lhyvaxap7k39sam3hh8rl0fq9rnc"))))
    (build-system gnu-build-system)
    (inputs
     `(("curl" ,curl)
@@ -4168,11 +4167,11 @@ for Un*x systems with X11.")
    (native-inputs
     `(("pkg-config" ,pkg-config)))
    (home-page "http://www.freeciv.org/")
-   (synopsis "Turn based empire building strategy game")
-   (description "Freeciv is a turn based empire building strategy game
+   (synopsis "Turn-based empire building strategy game")
+   (description "Freeciv is a turn-based empire building strategy game
 inspired by the history of human civilization.  The game commences in
 prehistory and your mission is to lead your tribe from the Stone Age
-to the Space Age.")
+into the Space Age.")
    (license license:gpl2+)))
 
 (define-public no-more-secrets
@@ -5182,7 +5181,7 @@ Crowther & Woods, its original authors, in 1995.  It has been known as
 (define-public tome4
   (package
     (name "tome4")
-    (version "1.6.4")
+    (version "1.6.5")
     (synopsis "Single-player, RPG roguelike game set in the world of Eyal")
     (source
      (origin
@@ -5191,7 +5190,7 @@ Crowther & Woods, its original authors, in 1995.  It has been known as
                            version ".tar.bz2"))
        (sha256
         (base32
-         "1hrh79aqmvwwd7idlr3lzpdpc9dgm1k5p7w2462chcjvd8vhfhb7"))
+         "0ifi057idid8xq7af8ybs99b6939hyfif1ml1ihjpx02vinmd419"))
        (modules '((guix build utils)))
        (snippet
         '(begin
@@ -5250,11 +5249,11 @@ Crowther & Woods, its original authors, in 1995.  It has been known as
                              (wrapper (string-append bin "/" ,name)))
                         ;; icon
                         (mkdir-p pixmaps)
-                        (system* unzip "-j"
-                                 (string-append
-                                  "game/engines/te4-" ,version ".teae")
-                                 (string-append
-                                  "data/gfx/" icon) "-d" pixmaps)
+                        (invoke unzip "-j"
+                                (string-append
+                                 "game/engines/te4-" ,version ".teae")
+                                (string-append
+                                 "data/gfx/" icon) "-d" pixmaps)
                         ;; game executable
                         (install-file "t-engine" data)
                         (mkdir-p bin)
@@ -7964,7 +7963,6 @@ can be downloaded from @url{https://zero.sjeng.org/best-network}.")
                           "/src/ktuberling-" version ".tar.xz"))
       (sha256
        (base32 "1qdf4q6wjh1lnlqw5c8z4rpj9w5vbyjfri1dah6yjm3mwppbc12j"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -8014,7 +8012,6 @@ This package is part of the KDE games module.")
                           "/src/picmi-" version ".tar.xz"))
       (sha256
        (base32 "0z9mpmv49w914gqdx274brdzl6d1bz9j9nkvbwgmr3iq1ba49m3f"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -8052,7 +8049,6 @@ This package is part of the KDE games module.")
                            "/src/kolf-" version ".tar.xz"))
        (sha256
         (base32 "06sfd0llr5cc3zf1vrpcxgw9bm009ky7y8822kynic9ipcd4z1hw"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -8132,7 +8128,6 @@ other Mah Jongg like games.")
                           version "/src/kmahjongg-" version ".tar.xz"))
       (sha256
        (base32 "08na845h0nhmfrszdmvfq5y1dy7kgbrlzjp0f5snvbbf7w44ci6p"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -8173,7 +8168,6 @@ This package is part of the KDE games module.")
                           version "/src/kshisen-" version ".tar.xz"))
       (sha256
        (base32 "1bq5m48af4h5apfp3bfsp76nlpv6h5sc0gd544zv7cgpfznz1sds"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -8213,7 +8207,6 @@ This package is part of the KDE games module.")
                           version "/src/kajongg-" version ".tar.xz"))
       (sha256
        (base32 "0ql6p5zifdpdf65r7ki9ml123azpwwk9x3x8r9ij6xhjnf7p7x6w"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -8258,7 +8251,6 @@ This package is part of the KDE games module.")
                           "/src/kbreakout-" version ".tar.xz"))
       (sha256
        (base32 "0gwzx1z9mxrjlcjzglg8cxkyd6900whcar3b5j9laxxarc6xhj8w"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -8297,7 +8289,6 @@ This package is part of the KDE games module.")
                           "/src/kmines-" version ".tar.xz"))
       (sha256
        (base32 "0ac3za36lh8hpx6mqfic9amwmzhzhzplm9hg3pw12gxl5a9mvfsf"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -8336,7 +8327,6 @@ This package is part of the KDE games module.")
                           version "/src/konquest-" version ".tar.xz"))
       (sha256
        (base32 "02gjxskhi10a1sqh3skcild8zria7wncz1a4sbz7ax1p851q76k1"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -8377,7 +8367,6 @@ This package is part of the KDE games module.")
                           version "/src/kbounce-" version ".tar.xz"))
       (sha256
        (base32 "02rfv0qzz5cmyfx8f56a45hbm9gsp6m3dcy8ajwx88rw5wpbrr11"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -8417,7 +8406,6 @@ This package is part of the KDE games module.")
                           version "/src/kblocks-" version ".tar.xz"))
       (sha256
        (base32 "0qrm0dihzhkxsq9l49ndzms802x6jn92vvabb2zf2q9z593m69cx"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -8459,7 +8447,6 @@ This package is part of the KDE games module.")
                           version "/src/ksudoku-" version ".tar.xz"))
       (sha256
        (base32 "0rcscz91hilm7l3am5w02n0n8l7xhi4l0n4sskznh68kblw0ggw2"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -8521,7 +8508,6 @@ This package is part of the KDE games module.")
                           "/src/klines-" version ".tar.xz"))
       (sha256
        (base32 "1g1f46jp0rb8gpqkgcf915ydpsscn1sxk3gjvm8bcqgx9ddq59xa"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -8566,7 +8552,6 @@ This package is part of the KDE games module.")
                            version ".tar.xz"))
       (sha256
        (base32 "16rcvq796r3asz4v4ap75xvwnxd3dd2nsq5r9vxvzl6rrf1w9bj4"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -8608,7 +8593,6 @@ This package is part of the KDE games module.")
                           "/src/kdiamond-" version ".tar.xz"))
       (sha256
        (base32 "1v5yb9hb26lk277zhw8d37ks829yfqr5anzx1qhms44gca5kqhva"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -8648,7 +8632,6 @@ This package is part of the KDE games module.")
                           "/src/kfourinline-" version ".tar.xz"))
       (sha256
        (base32 "1vprs6dc1ccn3g6k594i9s94xy4b91vzlqjysyc6fqcq2fs54ny3"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -8689,7 +8672,6 @@ This package is part of the KDE games module.")
                           "/src/kblackbox-" version ".tar.xz"))
       (sha256
        (base32 "1x42sfpf75c6mavwkc7g7dm11y9s5dpj8igphly5kvm0pajqby0n"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -8731,7 +8713,6 @@ This package is part of the KDE games module.")
                           "/src/knetwalk-" version ".tar.xz"))
       (sha256
        (base32 "1i340salzgqdw8y33wrrydmpgx3pvwf5wrbljlh67cjf6s4csx7d"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -8774,7 +8755,6 @@ This package is part of the KDE games module.")
                            "/src/bomber-" version ".tar.xz"))
        (sha256
         (base32 "1lvzd0mzgq25akvwvkm57l3plm65k731v2i1ahakn985bb5gc3is"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -8817,7 +8797,6 @@ This package is part of the KDE games module.")
                           "/src/granatier-" version ".tar.xz"))
       (sha256
        (base32 "141qmdinz7ikbbrs8dq6cap3nl22sl7pw62r80pf3xxwn2q4phpa"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -8856,7 +8835,6 @@ This package is part of the KDE games module.")
                           "/src/ksirk-" version ".tar.xz"))
        (sha256
         (base32 "1b1wixs2hp5qnvdygfwa3kvy0kn94ysa4ifmx90q6r3yfr2lpfca"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -8913,7 +8891,6 @@ This package is part of the KDE games module.")
                            "/src/palapeli-" version ".tar.xz"))
        (sha256
         (base32 "1g91ydbc0x2y2gn3lcb5w03mn7k78l5bq4cb1s59kx6yjbflv3pw"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -8962,7 +8939,6 @@ This package is part of the KDE games module.")
                            "/src/kiriki-" version ".tar.xz"))
        (sha256
         (base32 "1xg25dj95g81dc5l7k47am4j52abrwwfx4h73lvsbn4lc8lfmshw"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -9002,7 +8978,6 @@ This package is part of the KDE games module.")
                            "/src/kigo-" version ".tar.xz"))
        (sha256
         (base32 "00l5gcbi8xyj9c1lngkrddka3a4m4cd78prfplrpq32ma9xq681f"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -9050,7 +9025,6 @@ This package is part of the KDE games module.")
                            "/src/kubrick-" version ".tar.xz"))
        (sha256
         (base32 "0ma8wja4rqlsmsr8cyicfpkwlgqva4450ls4c0ql53p0kabf04gx"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -9093,7 +9067,6 @@ This package is part of the KDE games module.")
                            "/src/lskat-" version ".tar.xz"))
        (sha256
         (base32 "1qk5hd27zb42pbcxq5wyzz62nj5f0qdmgy54r9rnk92pzzzk94s9"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -9133,7 +9106,6 @@ This package is part of the KDE games module.")
                           "/src/kapman-" version ".tar.xz"))
       (sha256
        (base32 "03pq38caam30q4bw14c045kayw2d87xq1yaa3s2jkrylylfq3p0f"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -9174,7 +9146,6 @@ This package is part of the KDE games module.")
                            "/src/kspaceduel-" version ".tar.xz"))
        (sha256
         (base32 "1hppni0ihs7psc0dly5rxyy2a38nzhlig9yfyhi3lkh36z05pql8"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -9211,7 +9182,6 @@ This package is part of the KDE games module.")
                            "/src/bovo-" version ".tar.xz"))
        (sha256
         (base32 "0dbpng0w52nahmx7brsll66zw23ql1g6pcvn2k4g2lnvxch0i59g"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -9249,7 +9219,6 @@ This package is part of the KDE games module.")
                            "/src/killbots-" version ".tar.xz"))
        (sha256
         (base32 "1qi86q7diw7glkp9v33yim9nhz2da4balbxa1hjrdgjdv8zdbxbm"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -9292,7 +9261,6 @@ This package is part of the KDE games module.")
                           "/src/ksnakeduel-" version ".tar.xz"))
       (sha256
        (base32 "0mprrnpax8pv7ab36zwhvdfj8id52w8g6x76nnj8qvkdlkjiqdnn"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -9332,7 +9300,6 @@ This package is part of the KDE games module.")
                           "/src/kollision-" version ".tar.xz"))
       (sha256
        (base32 "1p7qrn3d0ybpvc9k6k5wzj54dsrp1rqh39844maz0ay2fhvmch12"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -9371,7 +9338,6 @@ This package is part of the KDE games module.")
 "/src/knavalbattle-" version ".tar.xz"))
       (sha256
        (base32 "0sdfjplqkb30x2mvh66pkzay6vn5px87779sh2s8lpl6fcw0v9g4"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -9413,7 +9379,6 @@ This package is part of the KDE games module.")
 "/src/kreversi-" version ".tar.xz"))
       (sha256
        (base32 "0b6q8df2bawgnrswhq59z37axad0q3zpvvzxdds7sz1lw505xw9h"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -9457,7 +9422,6 @@ This package is part of the KDE games module.")
                           "/src/ksquares-" version ".tar.xz"))
       (sha256
        (base32 "0hv8hls5s627lys08nnw72rfzsafj3dmp49mh2afzmh6lgk9h5vy"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -9495,7 +9459,6 @@ This package is part of the KDE games module.")
                           "/src/kjumpingcube-" version ".tar.xz"))
       (sha256
        (base32 "0d67zqkf2xffjkj671gl2n6nj6jajyn6rgqqj5i6gm500mqi9rm1"))))
-    (properties `((tags . ("Desktop" "KDE" "Games"))))
     (build-system qt-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)