summary refs log tree commit diff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm5
1 files changed, 0 insertions, 5 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index b4498c6a38..bb0f85360c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -986,12 +986,10 @@ in different ways.")
             (let* ((out (assoc-ref outputs "out"))
                    (inc (string-append out "/include"))
                    (lib (string-append out "/lib")))
-              (mkdir-p inc)
               (for-each
                (lambda (file)
                  (install-file file inc))
                '("glk.h" "glkstart.h" "gi_blorb.h" "gi_dispa.h" "Make.glkterm"))
-              (mkdir-p lib)
               (install-file "libglkterm.a" lib))
             #t))
         (delete 'configure))))          ; no configure script
@@ -1032,7 +1030,6 @@ using the @code{curses.h} library for screen control.")
           (lambda* (#:key outputs #:allow-other-keys)
             (let* ((out (assoc-ref outputs "out"))
                    (bin (string-append out "/bin")))
-              (mkdir-p bin)
               (install-file "glulxe" bin))
             #t))
         (delete 'configure))))          ; no configure script
@@ -2661,7 +2658,6 @@ Super Game Boy, BS-X Satellaview, and Sufami Turbo.")
                           (doc     (string-append out
                                                   "/share/doc/grue-hunter")))
                      (begin
-                       (mkdir out)
                        (copy-file tarball "grue-hunter.tar.gz")
                        (zero? (system* gzip "-d" "grue-hunter.tar.gz"))
                        (zero? (system* tar "xvf"  "grue-hunter.tar"))
@@ -2672,7 +2668,6 @@ Super Game Boy, BS-X Satellaview, and Sufami Turbo.")
                        (patch-shebang (string-append bin "/grue-hunter")
                                       (list perl))
 
-                       (mkdir-p doc)
                        (install-file "grue-hunter/AGPLv3.txt" doc))))))
     (inputs `(("perl" ,perl)
               ("tar" ,tar)