summary refs log tree commit diff
path: root/gnu/packages/gawk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gawk.scm')
-rw-r--r--gnu/packages/gawk.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index fd14b4c83e..84b5bd17a7 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -55,6 +55,14 @@
                           '((substitute* "extension/Makefile.in"
                               (("^.*: check-for-shared-lib-support" match)
                                (string-append "### " match))))
+                          '())
+
+                    ;; XXX FIXME prerelease libtool fails on MIPS in the
+                    ;; absence of /usr/bin/file.
+                    ,@(if (equal? "mips64el-linux" (or (%current-target-system)
+                                                       (%current-system)))
+                          '((substitute* "extension/configure"
+                              (("/usr/bin/file") (which "file"))))
                           '())))
                 %standard-phases)))
    (inputs `(("libsigsegv" ,libsigsegv)