summary refs log tree commit diff
path: root/gnu/packages/gawk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gawk.scm')
-rw-r--r--gnu/packages/gawk.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index 6185409fb7..84b5bd17a7 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -57,15 +57,12 @@
                                (string-append "### " match))))
                           '())
 
-                    ;; XXX FIXME gawk 4.1.1 was bootstrapped with a prerelease
-                    ;; libtool, which fails on MIPS in the absence of
-                    ;; /usr/bin/file.  As a temporary workaround, we patch
-                    ;; the configure script to hardcode use of the little
-                    ;; endian N32 ABI on MIPS.
+                    ;; XXX FIXME prerelease libtool fails on MIPS in the
+                    ;; absence of /usr/bin/file.
                     ,@(if (equal? "mips64el-linux" (or (%current-target-system)
                                                        (%current-system)))
                           '((substitute* "extension/configure"
-                              (("\\$emul") "elf32ltsmipn32")))
+                              (("/usr/bin/file") (which "file"))))
                           '())))
                 %standard-phases)))
    (inputs `(("libsigsegv" ,libsigsegv)