summary refs log tree commit diff
path: root/gnu/packages/gawk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gawk.scm')
-rw-r--r--gnu/packages/gawk.scm28
1 files changed, 12 insertions, 16 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index 802042665a..ad87043d96 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -36,24 +36,20 @@
              (base32 "0sss7rhpvizi2a88h6giv0i7w5h07s2fxkw3s6n1hqvcnhrfgbb0"))))
    (build-system gnu-build-system)
    (arguments
-    (case-lambda
-      ((system)
-       `(#:parallel-tests? #f             ; test suite fails in parallel
+    `(#:parallel-tests? #f                ; test suite fails in parallel
 
-         ;; Work around test failure on Cygwin.
-         #:tests? ,(not (string=? system "i686-cygwin"))
+      ;; Work around test failure on Cygwin.
+      #:tests? ,(not (string=? (%current-system) "i686-cygwin"))
 
-         #:phases (alist-cons-before
-                   'configure 'set-shell-file-name
-                   (lambda* (#:key inputs #:allow-other-keys)
-                     ;; Refer to the right shell.
-                     (let ((bash (assoc-ref inputs "bash")))
-                       (substitute* "io.c"
-                         (("/bin/sh")
-                          (string-append bash "/bin/bash")))))
-                   %standard-phases)))
-      ((system cross-system)
-       '(#:parallel-tests? #f))))
+      #:phases (alist-cons-before
+                'configure 'set-shell-file-name
+                (lambda* (#:key inputs #:allow-other-keys)
+                  ;; Refer to the right shell.
+                  (let ((bash (assoc-ref inputs "bash")))
+                    (substitute* "io.c"
+                      (("/bin/sh")
+                       (string-append bash "/bin/bash")))))
+                %standard-phases)))
    (inputs `(("libsigsegv" ,libsigsegv)))
    (home-page "http://www.gnu.org/software/gawk/")
    (synopsis "GNU implementation of the Awk programming language")