summary refs log tree commit diff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index c07fdd2c80..5e2783d0dc 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -745,7 +745,10 @@ It also includes runtime support libraries for these languages.")
                   (delete-file-recursively "texinfo")
                   (substitute* "configure"
                     (("host_tools=(.*)texinfo" _ before)
-                     (string-append "host_tools=" before)))))))
+                     (string-append "host_tools=" before)))
+                  ;; Fix building on arm* with gcc-4+
+                  (substitute* "gcc/config/arm/arm.c"
+                    (("arm_prog_mode") "arm_prgmode"))))))
     (supported-systems (fold delete %supported-systems
                              '("powerpc64le-linux" "riscv64-linux")))
     (native-inputs (list texinfo dejagnu))
@@ -778,6 +781,10 @@ It also includes runtime support libraries for these languages.")
                        (("/lib/ld\\.so\\.1")
                         (search-input-file
                           inputs #$(glibc-dynamic-linker matching-system))))
+                     (substitute* "gcc/config/i386/gnu.h"
+                       (("/lib/ld\\.so")
+                        (search-input-file
+                          inputs #$(glibc-dynamic-linker matching-system))))
                      (substitute* '("gcc/config/alpha/linux-elf.h"
                                     "gcc/config/arm/linux-elf.h"
                                     "gcc/config/i386/linux.h"
@@ -1267,7 +1274,6 @@ provides the GNU compiler for the Go programming language."))
     (version "0.24")
     (source (origin
              (method url-fetch)
-             ;; Used to be at isl.gforge.inria.fr.
              (uri (list (string-append "mirror://sourceforge/libisl/isl-"
                                        version ".tar.xz")
                         (string-append %gcc-infrastructure