summary refs log tree commit diff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index e10d45d80e..48ef72933d 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -240,6 +240,14 @@ where the OS part is overloaded to denote a specific ABI---into GCC
                 (("static char const sed_cmd_z\\[\\] =.*;")
                  "static char const sed_cmd_z[] = \"sed\";"))
 
+              (when (file-exists? "libbacktrace")
+                ;; GCC 4.8+ comes with libbacktrace.  By default it builds
+                ;; with -Werror, which fails with a -Wcast-qual error in glibc
+                ;; 2.21's stdlib-bsearch.h.  Remove -Werror.
+                (substitute* "libbacktrace/configure"
+                  (("WARN_FLAGS=(.*)-Werror" _ flags)
+                   (string-append "WARN_FLAGS=" flags))))
+
               ;; Add a RUNPATH to libstdc++.so so that it finds libgcc_s.
               ;; See <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=32354>
               ;; and <http://bugs.gnu.org/20358>.