summary refs log tree commit diff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index b26e93e886..bed277b1e0 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -566,6 +566,13 @@ as the 'native-search-paths' field."
                 (("libgcj(_bc)?_la_LDFLAGS =" ldflags _)
                  (string-append ldflags " -Wl,-rpath=$(libdir)")))))
            (add-after
+            'unpack 'patch-testsuite
+            ;; dejagnu-1.6 removes the 'absolute' command
+            (lambda _
+              (substitute* "libjava/testsuite/lib/libjava.exp"
+                (("absolute") "file normalize"))
+              #t))
+           (add-after
             'install 'install-javac-and-javap-wrappers
             (lambda _
               (let* ((javac  (assoc-ref %build-inputs "javac.in"))