summary refs log tree commit diff
path: root/gnu/packages/gd.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gd.scm')
-rw-r--r--gnu/packages/gd.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index f9864d7784..3b1def55e1 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -122,15 +122,16 @@ most common applications of GD involve website development.")
                                                   (assoc-ref %build-inputs i)))
                                  '("zlib" "png" "ft" "jpeg" "fontconfig"))
        #:tests? #f ;; Failed 1/2 test programs. 1/12 subtests failed.
-       #:phases (alist-cons-after
-                 'configure 'clear-autogenerated-files
-                 (lambda _
-                   ;; This file is autogenerated by its .PLS script at build
-                   ;; time, but file creation fails because that file already
-                   ;; exists in the distribution with non-writable
-                   ;; permissions, so delete it first.
-                   (delete-file "bdf_scripts/bdf2gdfont.pl"))
-                 %standard-phases)))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'configure 'clear-autogenerated-files
+           (lambda _
+             ;; This file is autogenerated by its .PLS script at build
+             ;; time, but file creation fails because that file already
+             ;; exists in the distribution with non-writable
+             ;; permissions, so delete it first.
+             (delete-file "bdf_scripts/bdf2gdfont.pl")
+             #t)))))
     (home-page "http://search.cpan.org/dist/GD")
     (synopsis "Perl interface to the GD graphics library")
     (description "GD.pm is an autoloadable interface module for libgd, a