summary refs log tree commit diff
path: root/gnu/packages/genimage.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/genimage.scm')
-rw-r--r--gnu/packages/genimage.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/genimage.scm b/gnu/packages/genimage.scm
index 7ad710082c..c9ed6258a0 100644
--- a/gnu/packages/genimage.scm
+++ b/gnu/packages/genimage.scm
@@ -50,7 +50,9 @@
               (file-name (string-append name "-" version "-checkout"))
               (sha256
                (base32
-                "15jmh17lvm3jw9c92bjarly7iwhmnfl322d91mprfv10ppb9ip54"))))
+                "15jmh17lvm3jw9c92bjarly7iwhmnfl322d91mprfv10ppb9ip54"))
+              ;; will be shipped with release 14
+              (patches (search-patches "genimage-signedness.patch"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases
@@ -169,7 +171,6 @@
        ("automake" ,automake)
        ;;; Note: cramfs is obsolete.
        ("dtc" ,dtc) ; for the tests
-       ("fdisk" ,fdisk) ; for the tests
        ("pkg-config" ,pkg-config)
        ("util-linux" ,util-linux))) ; for the tests
     (inputs