summary refs log tree commit diff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm41
1 files changed, 21 insertions, 20 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 5e1f7e39d7..bb9f897e51 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -30,6 +30,7 @@
   #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system go)
+  #:use-module (guix build-system meson)
   #:use-module (guix build-system python)
   #:use-module (guix build-system scons)
   #:use-module (guix build-system r)
@@ -107,7 +108,7 @@ topology functions.")
 (define-public gnome-maps
   (package
     (name "gnome-maps")
-    (version "3.28.2")
+    (version "3.30.3.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/" name "/"
@@ -115,28 +116,25 @@ topology functions.")
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "1yzi08a9316jplgsl2z0qzlqxhghyqcjhv0m6i94wcain4mxk1z7"))))
-    (build-system glib-or-gtk-build-system)
+                "0xqk3yrds0w8bjmpf4jw0370phvm65av82nqrx7fp1648h9nq7xi"))))
+    (build-system meson-build-system)
     (arguments
-     `(#:configure-flags ;; Ensure that geoclue is referred to by output.
-       (list (string-append "LDFLAGS=-L"
-                            (assoc-ref %build-inputs "geoclue") "/lib")
-             (string-append "CFLAGS=-I"
-                            (assoc-ref %build-inputs "geoclue") "/include"))
+     `(#:glib-or-gtk? #t
        #:phases
        (modify-phases %standard-phases
          (add-after 'install 'wrap
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out"))
                    (gi-typelib-path (getenv "GI_TYPELIB_PATH"))
-                   (goa-path (string-append
-                              (assoc-ref inputs "gnome-online-accounts")
-                              "/lib:"
-                              (assoc-ref inputs "gnome-online-accounts:lib")
-                              "/lib"))
                    (geocode-glib-path (string-append
                                        (assoc-ref inputs "geocode-glib")
                                        "/lib"))
+                   (goa-path (string-append
+                              (assoc-ref inputs "gnome-online-accounts:lib")
+                              "/lib"))
+                   (gdk-pixbuf-path (string-append
+                                     (assoc-ref inputs "gdk-pixbuf")
+                                     "/lib"))
                    (webkitgtk-path (string-append
                                     (assoc-ref inputs "webkitgtk")
                                     "/lib")))
@@ -144,13 +142,17 @@ topology functions.")
                  `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
 
                  ;; There seems to be no way to embed the path of
-                 ;; libgoa-1.0.so.0, libwebkit2gtk-4.0.so.37 and
-                 ;; libjavascriptcoregtk-4.0.so.18.
-                 `("LD_LIBRARY_PATH" ":" prefix
-                   (,goa-path ,webkitgtk-path ,geocode-glib-path)))
+                 ;; libgoa-1.0.so.0, libwebkit2gtk-4.0.so.37,
+                 ;; libgdk_pixbuf-2.0.so, libjavascriptcoregtk-4.0.so.18, and
+                 ;; libgeocode-glib.so.0
+                 `("LD_LIBRARY_PATH" ":" prefix (,goa-path
+                                                 ,webkitgtk-path
+                                                 ,gdk-pixbuf-path
+                                                 ,geocode-glib-path)))
                #t))))))
     (native-inputs
-     `(("gobject-introspection" ,gobject-introspection)
+     `(("gtk+" ,gtk+ "bin") ; gtk-update-icon-cache
+       ("gobject-introspection" ,gobject-introspection)
        ("intltool" ,intltool)
        ("pkg-config" ,pkg-config)))
     (inputs
@@ -161,14 +163,13 @@ topology functions.")
        ("libsoup" ,libsoup)
        ("libgweather" ,libgweather)
        ("libxml2" ,libxml2)
-       ("gdk-pixbuf" ,gdk-pixbuf)
+       ("gdk-pixbuf" ,gdk-pixbuf+svg)
        ("glib-networking" ,glib-networking)
        ("geoclue" ,geoclue)
        ("geocode-glib" ,geocode-glib)
        ("gfbgraph" ,gfbgraph)
        ("gjs" ,gjs)
        ("glib" ,glib)
-       ("gnome-online-accounts" ,gnome-online-accounts)
        ("gnome-online-accounts:lib" ,gnome-online-accounts "lib")
        ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
        ("rest" ,rest)