summary refs log tree commit diff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm17
1 files changed, 3 insertions, 14 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 0b95fbe613..94f2cf0cfb 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -668,21 +668,15 @@ extension.")
     (build-system go-build-system)
     (arguments
      `(#:import-path "github.com/go-spatial/tegola/cmd/tegola"
-       #:unpack-path "github.com/go-spatial"
+       #:unpack-path "github.com/go-spatial/tegola"
        #:phases
        (modify-phases %standard-phases
          (add-before 'build 'set-version
            (lambda _
-             (with-directory-excursion
-               (string-append "src/github.com/go-spatial/tegola-" ,version)
+             (with-directory-excursion "src/github.com/go-spatial/tegola"
                (substitute* '("cmd/tegola/cmd/root.go"
                               "cmd/tegola_lambda/main.go")
                  (("version not set") ,version)))
-             #t))
-         (add-before 'build 'rename-import
-           (lambda _
-             (rename-file (string-append "src/github.com/go-spatial/tegola-" ,version)
-                          "src/github.com/go-spatial/tegola")
              #t)))))
     (home-page "http://tegola.io")
     (synopsis "Vector tile server for maps")
@@ -713,14 +707,9 @@ delivered to any client.")
     (build-system go-build-system)
     (arguments
      `(#:import-path "github.com/omniscale/imposm3/cmd/imposm"
-       #:unpack-path "github.com/omniscale"
+       #:unpack-path "github.com/omniscale/imposm3"
        #:phases
        (modify-phases %standard-phases
-         (add-before 'build 'rename-import
-           (lambda _
-             (rename-file (string-append "src/github.com/omniscale/imposm3-" ,version)
-                          "src/github.com/omniscale/imposm3")
-             #t))
          (add-before 'build 'set-version
            (lambda _
              (substitute* "src/github.com/omniscale/imposm3/version.go"