summary refs log tree commit diff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm36
1 files changed, 35 insertions, 1 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 8a4d841142..f51d1c0cea 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -561,6 +561,14 @@ development.")
        ("sqlite" ,sqlite)
        ("wxwidgets" ,wxwidgets-2)
        ("zlib" ,zlib)))
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'fix-gui
+                    (lambda _
+                      ;; Fix for the GUI not showing up.
+                      (substitute* "Main.cpp"
+                        (("Hide\\(\\);") ""))
+                      #t)))))
     (synopsis "Graphical user interface for SpatiaLite")
     (description "Spatialite-gui provides a visual interface for viewing and
  maintaining a spatialite database.  You can easily see the structure of the
@@ -768,7 +776,7 @@ extension.")
                               "cmd/tegola_lambda/main.go")
                  (("version not set") ,version)))
              #t)))))
-    (home-page "http://tegola.io")
+    (home-page "https://tegola.io")
     (synopsis "Vector tile server for maps")
     (description "Tegola is a free vector tile server written in Go.  Tegola
 takes geospatial data and slices it into vector tiles that can be efficiently
@@ -1507,3 +1515,29 @@ input file (in @code{.osm} or @code{.osm.pbf} format).")
 tools supporting SpatiaLite.")
     (home-page "https://www.gaia-gis.it/fossil/spatialite-tools/index")
     (license license:gpl3+)))
+
+(define-public virtualpg
+  (package
+    (name "virtualpg")
+    (version "1.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://www.gaia-gis.it/gaia-sins/"
+                           "virtualpg-" version ".tar.gz"))
+       (sha256
+        (base32 "0kjipcd08vvn188xmwbs7sw41xcs06x47n2hbqshpjcr51mxbarp"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("postgresql" ,postgresql)
+       ("sqlite" ,sqlite)))
+    (synopsis "Allow SQLite/SpatiaLite to access PostgreSQL/PostGIS tables")
+    (description
+     "VirtualPG is a dynamic extension for the SQLite DBMS.  It implements
+the VirtualPostgres driver, allowing to directly exchange data between SQLite
+and PostgreSQL; if SpatiaLite is available even PostGIS geometries can be
+exchanged form one Spatial DBMS and the other.")
+    (home-page "https://www.gaia-gis.it/fossil/virtualpg/index")
+    (license (list license:gpl2+
+                   license:lgpl2.1+
+                   license:mpl1.1))))