summary refs log tree commit diff
path: root/gnu/packages/gettext.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gettext.scm')
-rw-r--r--gnu/packages/gettext.scm29
1 files changed, 16 insertions, 13 deletions
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index 29ea54924a..e22b1ba6ff 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -38,19 +38,22 @@
     (build-system gnu-build-system)
     (arguments
      `(#:patches (list (assoc-ref %build-inputs "patch/gets"))
-       #:phases (alist-cons-before
-                 'check 'patch-tests
-                 (lambda* (#:key inputs #:allow-other-keys)
-                   (let ((bash (assoc-ref inputs "bash")))
-                     (substitute* (find-files "gettext-tools/tests"
-                                              "^msgexec-[0-9]")
-                       (("#![[:blank:]]/bin/sh")
-                        (format #f "#!~a/bin/sh" bash)))
-                     (substitute* (find-files "gettext-tools/gnulib-tests"
-                                              "posix_spawn")
-                       (("/bin/sh")
-                        (format #f "~a/bin/bash" bash)))))
-                 %standard-phases)))
+       #:phases ,(if (%current-target-system)
+                     '%standard-cross-phases
+                     '(alist-cons-before
+                       'check 'patch-tests
+                       (lambda* (#:key inputs #:allow-other-keys)
+                         ;; TODO: Use (which "sh").
+                         (let ((bash (assoc-ref inputs "bash")))
+                           (substitute* (find-files "gettext-tools/tests"
+                                                    "^msgexec-[0-9]")
+                             (("#![[:blank:]]/bin/sh")
+                              (format #f "#!~a/bin/sh" bash)))
+                           (substitute* (find-files "gettext-tools/gnulib-tests"
+                                                    "posix_spawn")
+                             (("/bin/sh")
+                              (format #f "~a/bin/bash" bash)))))
+                       %standard-phases))))
     (inputs
      `(("patch/gets"
         ,(search-patch "gettext-gets-undeclared.patch"))))