summary refs log tree commit diff
path: root/gnu/packages/gimp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gimp.scm')
-rw-r--r--gnu/packages/gimp.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index d69425fde9..5e46eb36b7 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -227,8 +227,6 @@ provided, as well as a framework to add new color models and data types.")
     (build-system meson-build-system)
     (arguments
      `(#:meson ,meson-0.55
-       #:configure-flags
-       (list "-Dintrospection=false")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'extend-test-time-outs
@@ -254,9 +252,11 @@ provided, as well as a framework to add new color models and data types.")
        ("libpng" ,libpng)
        ("libjpeg" ,libjpeg-turbo)))
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("glib" ,glib "bin")             ; for gtester
-       ("intltool" ,intltool)))
+     `(("glib" ,glib "bin")             ; for gtester
+       ("gobject-introspection" ,gobject-introspection)
+       ("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)
+       ("vala" ,vala)))
     (home-page "https://gegl.org")
     (synopsis "Graph based image processing framework")
     (description "GEGL (Generic Graphics Library) provides infrastructure to