summary refs log tree commit diff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 132dc63970..4be45ff3d7 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -387,6 +387,11 @@ also known as DXTn or DXTC) for Mesa.")
                   ;; report: <https://bugs.freedesktop.org/show_bug.cgi?id=110612>.
                   `((substitute* "src/util/tests/format/meson.build"
                       (("'u_format_test',") ""))))
+                 ("aarch64-linux"
+                  ;; The ir3_disasm test segfaults.
+                  ;; The simplest way to skip it is to run a different test instead.
+                  `((substitute* "src/freedreno/ir3/meson.build"
+                      (("disasm\\.c'") "delay.c',\n    link_args: ld_args_build_id"))))
                  (_
                   '((display "No tests to disable on this architecture.\n"))))))
          (add-after 'unpack 'fix-tests