summary refs log tree commit diff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm37
1 files changed, 21 insertions, 16 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index a6935d4189..e8003f88a3 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -409,22 +409,27 @@ extension functionality is exposed in a single header file.")
               ("glu" ,glu)
               ("freeglut" ,freeglut)))
     (arguments
-     '(#:phases (alist-cons-before
-                 'build 'patch-dynamic-link
-                 (lambda* (#:key inputs outputs #:allow-other-keys)
-                   (define (dynamic-link-substitute file lib input)
-                     (substitute* file
-                       (("dynamic-link \"lib([a-zA-Z]+)\"" _ lib)
-                        (string-append "dynamic-link \""
-                                       (assoc-ref inputs input)
-                                       "/lib/lib" lib "\""))))
-                   ;; Replace dynamic-link calls for libGL, libGLU, and
-                   ;; libglut with absolute paths to the store.
-                   (dynamic-link-substitute "glx/runtime.scm" "GL" "mesa")
-                   (dynamic-link-substitute "glu/runtime.scm" "GLU" "glu")
-                   (dynamic-link-substitute "glut/runtime.scm" "glut"
-                                            "freeglut"))
-                 %standard-phases)))
+     '(#:phases (modify-phases %standard-phases
+                 (add-after 'configure 'patch-makefile
+                   (lambda _
+                     ;; Install compiled Guile files in the expected place.
+                     (substitute* '("Makefile")
+                       (("^godir = .*$")
+                        "godir = $(moddir)\n"))))
+                 (add-before 'build 'patch-dynamic-link
+                   (lambda* (#:key inputs outputs #:allow-other-keys)
+                     (define (dynamic-link-substitute file lib input)
+                       (substitute* file
+                         (("dynamic-link \"lib([a-zA-Z]+)\"" _ lib)
+                          (string-append "dynamic-link \""
+                                         (assoc-ref inputs input)
+                                         "/lib/lib" lib "\""))))
+                     ;; Replace dynamic-link calls for libGL, libGLU, and
+                     ;; libglut with absolute paths to the store.
+                     (dynamic-link-substitute "glx/runtime.scm" "GL" "mesa")
+                     (dynamic-link-substitute "glu/runtime.scm" "GLU" "glu")
+                     (dynamic-link-substitute "glut/runtime.scm" "glut"
+                                              "freeglut"))))))
     (home-page "http://gnu.org/s/guile-opengl")
     (synopsis "Guile binding for the OpenGL graphics API")
     (description