summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm22
1 files changed, 5 insertions, 17 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c1c73f0f74..7f7880429a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -954,7 +954,6 @@ the GNOME desktop environment.")
 (define-public libcroco
   (package
     (name "libcroco")
-    (replacement libcroco/fixed)
     (version "0.6.11")
     (source (origin
               (method url-fetch)
@@ -963,7 +962,9 @@ the GNOME desktop environment.")
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "0mm0wldbi40am5qn0nv7psisbg01k42rwzjxl3gv11l5jj554aqk"))))
+                "0mm0wldbi40am5qn0nv7psisbg01k42rwzjxl3gv11l5jj554aqk"))
+              (patches (search-patches "libcroco-CVE-2017-7960.patch"
+                                       "libcroco-CVE-2017-7961.patch"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)))
@@ -982,19 +983,6 @@ XML/CSS rendering engine.")
     ;; LGPLv2.1-only.
     (license license:lgpl2.1)))
 
-(define libcroco/fixed
-  (package
-    (inherit libcroco)
-    (replacement #f)
-    (source
-      (origin
-        (inherit (package-source libcroco))
-        (patches
-          (append
-            (origin-patches (package-source libcroco))
-            (search-patches "libcroco-CVE-2017-7960.patch"
-                            "libcroco-CVE-2017-7961.patch")))))))
-
 (define-public libgsf
   (package
     (name "libgsf")
@@ -1031,7 +1019,7 @@ dealing with different structured file formats.")
 (define-public librsvg
   (package
     (name "librsvg")
-    (version "2.40.16")
+    (version "2.40.17")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/" name "/"
@@ -1039,7 +1027,7 @@ dealing with different structured file formats.")
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "0bpz6gsq8xi1pb5k9ax6vinph460v14znch3y5yz167s0dmwz2yl"))))
+                "1k39gyf7f5m9x0jvpcxvfcqswdb04xhm1lbwbjabn1f4xk5wbxp6"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases