summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 497713cddc..47eb552603 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6573,7 +6573,14 @@ DAV, and others.")
      `(("glib" ,glib)
        ("libusb" ,libusb)))
     (arguments
-     `(#:tests? #f)) ;libusb fails to initialize.  Wonder what that is.
+     `(#:tests? #f ;libusb fails to initialize.  Wonder what that is.
+       #:configure-flags
+       ,(if (%current-target-system)
+            ;; Introspection data cannot currently be cross-compiled.
+            ''("-Dintrospection=false"
+               ;; Requires introspection data.
+               "-Dvapi=false")
+            ''())))
     (home-page "https://github.com/hughsie/libgusb")
     (synopsis "GLib binding for libusb1")
     (description