summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 058d245a0b..446883c777 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8183,7 +8183,9 @@ the archive.")
                        (version-major+minor version) "/"
                        name "-" version ".tar.xz"))
        (sha256
-        (base32 "0ymvf1bap35348rpjqp63qwnwnnawdwi4snch95zc4n832w3hjym"))))
+        (base32 "0ymvf1bap35348rpjqp63qwnwnnawdwi4snch95zc4n832w3hjym"))
+       (patches
+        (search-patches "gnome-session-elogind.patch"))))
     (build-system meson-build-system)
     (outputs '("out" "doc"))
     (arguments
@@ -8235,7 +8237,8 @@ the archive.")
        ("xmlto" ,xmlto)
        ("xsltproc" ,libxslt)))
     (inputs
-     `(("epoxy" ,libepoxy)
+     `(("elogind" ,elogind)
+       ("epoxy" ,libepoxy)
        ("glib" ,glib)
        ("gnome-desktop" ,gnome-desktop)
        ("gtk+" ,gtk+)