summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4df79bb442..a71e7f86dd 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3063,7 +3063,7 @@ configuring CUPS.")
              #t)))))
     (propagated-inputs
      `(;; In Requires of libnotify.pc.
-       ("gdk-pixbuf" ,gdk-pixbuf+svg)
+       ("gdk-pixbuf" ,gdk-pixbuf)
        ("glib" ,glib)))
     (inputs
      `(("gtk+" ,gtk+)
@@ -3286,11 +3286,11 @@ XML/CSS rendering engine.")
        ("perl" ,perl)
        ("perl-xml-parser" ,perl-xml-parser)))
     (inputs
-     `(("gdk-pixbuf" ,gdk-pixbuf)
-       ("zlib" ,zlib)
+     `(("zlib" ,zlib)
        ("bzip2" ,bzip2)))
     (propagated-inputs
-     `(("glib" ,glib)
+     `(("gdk-pixbuf" ,gdk-pixbuf)
+       ("glib" ,glib)
        ("libxml2" ,libxml2)))
     (home-page "https://www.gnome.org/projects/libgsf")
     (synopsis "GNOME's Structured File Library")
@@ -3357,11 +3357,11 @@ dealing with different structured file formats.")
        ("libcroco" ,libcroco)
        ("bzip2" ,bzip2)
        ("libgsf" ,libgsf)
-       ("gdk-pixbuf" ,gdk-pixbuf)
        ("libxml2" ,libxml2)))
     (propagated-inputs
      ;; librsvg-2.0.pc refers to all of that.
      `(("cairo" ,cairo)
+       ("gdk-pixbuf" ,gdk-pixbuf)
        ("glib" ,glib)))
     (home-page "https://wiki.gnome.org/LibRsvg")
     (synopsis "Render SVG files using Cairo")
@@ -3536,7 +3536,6 @@ library.")
      `(("bzip2" ,bzip2)
        ("fontconfig" ,fontconfig)
        ("freetype" ,freetype)
-       ("gdk-pixbuf" ,gdk-pixbuf)
        ("harfbuzz" ,harfbuzz)
        ("libcroco" ,libcroco)
        ("libgsf" ,libgsf)
@@ -3544,6 +3543,7 @@ library.")
        ("pango" ,pango)))
     (propagated-inputs
      `(("cairo" ,cairo)
+       ("gdk-pixbuf" ,gdk-pixbuf)
        ("glib" ,glib)))
     (synopsis "SVG rendering library")
     (description "Librsvg is a library to render SVG images to Cairo surfaces.
@@ -5446,7 +5446,7 @@ service via the system message bus.")
      ;; gweather-3.0.pc refers to GTK+, GDK-Pixbuf, GLib/GObject, libxml, and
      ;; libsoup.
      `(("gtk+" ,gtk+)
-       ("gdk-pixbuf" ,gdk-pixbuf+svg)
+       ("gdk-pixbuf" ,gdk-pixbuf)
        ("libxml2" ,libxml2)
        ("libsoup" ,libsoup)
        ("geocode-glib" ,geocode-glib)))
@@ -5711,7 +5711,7 @@ throughout GNOME for API documentation).")
        ("pkg-config" ,pkg-config)))
     (propagated-inputs
      `(("glib" ,glib)
-       ("gdk-pixbuf" ,gdk-pixbuf+svg)
+       ("gdk-pixbuf" ,gdk-pixbuf)
        ("libx11" ,libx11)
        ("libxext" ,libxext)
        ("libxfixes" ,libxfixes)
@@ -7384,7 +7384,7 @@ to display dialog boxes from the commandline and shell scripts.")
        ;; mutter-clutter-1.0.pc and mutter-cogl-1.0.pc refer to these:
        ("atk" ,atk)
        ("cairo" ,cairo)
-       ("gdk-pixbuf" ,gdk-pixbuf+svg)
+       ("gdk-pixbuf" ,gdk-pixbuf)
        ("glib" ,glib)
        ("json-glib" ,json-glib)
        ("libinput" ,libinput)
@@ -10484,7 +10484,7 @@ photo-booth-like software, such as Cheese.")
        ("clutter-gst" ,clutter-gst)
        ("clutter-gtk" ,clutter-gtk)
        ("libcanberra" ,libcanberra)
-       ("gdk-pixbuf" ,gdk-pixbuf+svg)
+       ("gdk-pixbuf" ,gdk-pixbuf)
        ("glib" ,glib)
        ("gstreamer" ,gstreamer)))
     (inputs