summary refs log tree commit diff
path: root/gnu/packages/gnunet.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnunet.scm')
-rw-r--r--gnu/packages/gnunet.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 0f5f32b9b4..69cd74ee66 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -20,15 +20,18 @@
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages curl)
+  #:use-module (gnu packages geeqie)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages gnutls)
+  #:use-module (gnu packages gstreamer)
   #:use-module (gnu packages libjpeg)
   #:use-module (gnu packages libtiff)
   #:use-module (gnu packages oggvorbis)
   #:use-module (gnu packages openssl)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages video)
   #:use-module ((guix licenses)
                 #:renamer (symbol-prefix-proc 'license:))
   #:use-module (guix packages)
@@ -53,13 +56,10 @@
    ;; The following dependencies are all optional, but should be
    ;; available for maximum coverage:
    ;; * libarchive
-   ;; * libavutil / libavformat / libavcodec / libswscale (ffmpeg)
-   ;; * libexiv2
    ;; * libgif (giflib)
    ;; * libgtk+ >= 3.0.0 (may probably drop glib then as a propagated input of
    ;;                     gtk)
    ;; * libgsf
-   ;; * libgstreamer
    ;; * libmagic (file)
    ;; * libmpeg2
    ;; * libmp4v2
@@ -67,9 +67,13 @@
    ;; * libsmf
    ;; * libtidy
    (inputs
-    `(("gettext" ,gnu-gettext)
+    `(("exiv2" ,exiv2)
       ("flac" ,flac)
+      ("ffmpeg" ,ffmpeg)
+      ("gettext" ,gnu-gettext)
       ("glib" ,glib)
+      ("gstreamer" ,gstreamer)
+      ("gst-plugins-base" ,gst-plugins-base)
       ("libjpeg" ,libjpeg)
       ("libogg" ,libogg)
       ("libtiff" ,libtiff)