summary refs log tree commit diff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 08fa1570d6..90215a6877 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -285,6 +285,7 @@ compatible to GNU Pth.")
     ;; Note2: 2.2.33 currently suffers from regressions, so do not update to it
     ;; (see: https://dev.gnupg.org/T5742).
     (version "2.2.32")
+    (replacement gnupg/fixed)
     (source (origin
               (method url-fetch)
               (uri (string-append "ftp://ftp.gnupg.org/gcrypt/gnupg/gnupg-" version
@@ -352,6 +353,15 @@ libskba (working with X.509 certificates and CMS data).")
     (properties '((ftp-server . "ftp.gnupg.org")
                   (ftp-directory . "/gcrypt/gnupg")))))
 
+(define gnupg/fixed
+  (package
+    (inherit gnupg)
+    (source (origin
+              (inherit (package-source gnupg))
+              (patches
+                (append (origin-patches (package-source gnupg))
+                        (search-patches "gnupg-CVE-2022-34903.patch")))))))
+
 (define-public gnupg-1
   (package (inherit gnupg)
     (version "1.4.23")