summary refs log tree commit diff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm72
1 files changed, 72 insertions, 0 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 3ebc20dffa..a60ff76298 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -42,6 +42,78 @@
   #:use-module (gnu packages yasm)
   #:use-module (gnu packages zip))
 
+(define-public mozjs
+  (package
+    (name "mozjs")
+    (version "17.0.0")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append
+                   "https://ftp.mozilla.org/pub/mozilla.org/js/"
+                   name version ".tar.gz"))
+             (sha256
+              (base32
+               "1fig2wf4f10v43mqx67y68z6h77sy900d1w0pz9qarrqx57rc7ij"))))
+    (build-system gnu-build-system)
+    (native-inputs
+      `(("perl", perl)
+        ("python" ,python-2)))
+    (arguments
+      `(#:phases
+          (alist-cons-before
+           'configure 'chdir
+           (lambda _
+             (chdir "js/src"))
+           (alist-replace
+            'configure
+            ;; configure fails if it is followed by SHELL and CONFIG_SHELL
+            (lambda* (#:key outputs #:allow-other-keys)
+              (let ((out (assoc-ref outputs "out")))
+                (setenv "SHELL" (which "sh"))
+                (setenv "CONFIG_SHELL" (which "sh"))
+                (zero? (system*
+                        "./configure" (string-append "--prefix=" out)))))
+            %standard-phases))))
+    (home-page
+     "https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey")
+    (synopsis "Mozilla javascript engine")
+    (description "SpiderMonkey is Mozilla's JavaScript engine written
+in C/C++.")
+    (license license:mpl2.0))) ; and others for some files
+
+(define-public nspr
+  (package
+    (name "nspr")
+    (version "4.10.7")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append
+                   "https://ftp.mozilla.org/pub/mozilla.org/nspr/releases/v"
+                   version "/src/nspr-" version ".tar.gz"))
+             (sha256
+              (base32
+               "0f1ri51yzjikigf6z31g03cdv6sgi9gw2c3vvv39psk3m37zb6iq"))))
+    (build-system gnu-build-system)
+    (native-inputs
+      `(("perl", perl)))
+    (arguments
+      `(#:tests? #f ; no check target
+        #:configure-flags
+        `("--enable-64bit")
+        #:phases
+          (alist-cons-before
+           'configure 'chdir
+           (lambda _
+             (chdir "nspr"))
+            %standard-phases)))
+    (home-page
+     "https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSPR")
+    (synopsis "Netscape API for system level and libc-like functions")
+    (description "Netscape Portable Runtime (NSPR) provides a
+platform-neutral API for system level and libc-like functions.  It is used
+in the Mozilla clients.")
+    (license license:mpl2.0)))
+
 (define-public icecat
   (package
     (name "icecat")