summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 485aa02c46..c6fc68468f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -195,7 +195,7 @@
        ;; https://github.com/golang/go/issues/24046
        ("gcc:lib" ,gcc-6 "lib")))
     (native-inputs
-     `(("pkg-config" ,%pkg-config)
+     `(("pkg-config" ,pkg-config)
        ("which" ,which)
        ("net-base" ,net-base)
        ("perl" ,perl)))
@@ -214,7 +214,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
   (package
     (inherit go-1.4)
     (name "go")
-    (version "1.9.4")
+    (version "1.9.5")
     (source
      (origin
        (method url-fetch)
@@ -222,7 +222,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
                            name version ".src.tar.gz"))
        (sha256
         (base32
-         "01nw8rfvf10naja0wq0kabsm012sbqq76hd4b8c7g28n6ggshwq5"))))
+         "1g4zqhbh1yw3gnb400szzwrdz0k5s3h0h5nc35xgmn5v69zvphpi"))))
     (arguments
      (substitute-keyword-arguments (package-arguments go-1.4)
        ((#:phases phases)
@@ -292,6 +292,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
                     ("syscall/syscall_unix_test.go" "(.+)(TestPassFD\\(.+)")
                     ("os/exec/exec_test.go" "(.+)(TestExtraFiles/areturn.+)")
                     ("cmd/go/go_test.go" "(.+)(TestCoverageWithCgo.+)")
+                    ("cmd/go/go_test.go" "(.+)(TestTwoPkgConfigs.+)")
                     ("os/exec/exec_test.go" "(.+)(TestOutputStderrCapture.+)")
                     ("os/exec/exec_test.go" "(.+)(TestExtraFiles.+)")
                     ("os/exec/exec_test.go" "(.+)(TestExtraFilesRace.+)")
@@ -382,7 +383,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
   (package
     (inherit go-1.9)
     (name "go")
-    (version "1.10")
+    (version "1.10.1")
     (source
      (origin
        (method url-fetch)
@@ -390,7 +391,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
                            name version ".src.tar.gz"))
        (sha256
         (base32
-         "093z1h0gmi458kv7smpx0ph6jm7ss9mzxa432kysbz85jhl4kppk"))))
+         "1p1xyyxicp752n9wj10sljjl6mjxpfsplkhx74fzzjrwdkzlk52q"))))
     (arguments
      (substitute-keyword-arguments (package-arguments go-1.9)
        ((#:phases phases)
@@ -460,6 +461,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
                     ("syscall/syscall_unix_test.go" "(.+)(TestPassFD\\(.+)")
                     ("os/exec/exec_test.go" "(.+)(TestExtraFiles/areturn.+)")
                     ("cmd/go/go_test.go" "(.+)(TestCoverageWithCgo.+)")
+                    ("cmd/go/go_test.go" "(.+)(TestTwoPkgConfigs.+)")
                     ("os/exec/exec_test.go" "(.+)(TestOutputStderrCapture.+)")
                     ("os/exec/exec_test.go" "(.+)(TestExtraFiles.+)")
                     ("os/exec/exec_test.go" "(.+)(TestExtraFilesRace.+)")