summary refs log tree commit diff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm168
1 files changed, 78 insertions, 90 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index aa026c60e3..4b4385d3ff 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015, 2016, 2021 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015 Tomáš Čech <sleep_walker@gnu.org>
 ;;; Copyright © 2016, 2019 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2016, 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
@@ -21,7 +21,7 @@
 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
 ;;; Copyright © 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
-;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2020 Gabriel Arazas <foo.dogsquared@gmail.com>
 ;;; Copyright © 2021 Antoine Côté <antoine.cote@posteo.net>
 ;;; Copyright © 2021 Andy Tai <atai@atai.org>
@@ -487,7 +487,7 @@ applications.")
      `(("boost" ,boost)
        ("c-blosc" ,c-blosc)
        ("ilmbase" ,ilmbase)
-       ("tbb" ,tbb)
+       ("tbb" ,tbb-2020)
        ("zlib" ,zlib)))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
@@ -553,14 +553,19 @@ typically encountered in feature film production.")
                #t))
            (add-after 'set-paths 'add-ilmbase-include-path
              (lambda* (#:key inputs #:allow-other-keys)
-               ;; OpenEXR propagates ilmbase, but its include files do not appear
-               ;; in the CPATH, so we need to add "$ilmbase/include/OpenEXR/" to
-               ;; the CPATH to satisfy the dependency on "half.h".
-               (setenv "CPATH"
-                       (string-append (assoc-ref inputs "ilmbase")
-                                      "/include/OpenEXR"
-                                      ":" (or (getenv "CPATH") "")))
-               #t))))))
+               ;; OpenEXR propagates ilmbase, but its include files do not
+               ;; appear in the C_INCLUDE_PATH, so we need to add
+               ;; "$ilmbase/include/OpenEXR/" to the C_INCLUDE_PATH to satisfy
+               ;; the dependency on "half.h" and "Iex.h".
+               (let ((headers (string-append
+                               (assoc-ref inputs "ilmbase")
+                               "/include/OpenEXR")))
+                 (setenv "C_INCLUDE_PATH"
+                         (string-append headers ":"
+                                        (or (getenv "C_INCLUDE_PATH") "")))
+                 (setenv "CPLUS_INCLUDE_PATH"
+                         (string-append headers ":"
+                                        (or (getenv "CPLUS_INCLUDE_PATH") ""))))))))))
     (inputs
      `(("boost" ,boost)
        ("jemalloc" ,jemalloc)
@@ -587,7 +592,7 @@ typically encountered in feature film production.")
        ("python" ,python)
        ("python-numpy" ,python-numpy)
        ("openvdb" ,openvdb)
-       ("tbb" ,tbb)
+       ("tbb" ,tbb-2020)
        ("zlib" ,zlib)
        ("embree" ,embree)))
     (home-page "https://blender.org/")
@@ -659,10 +664,9 @@ application can be customized via its API for Python scripting.")
                ;; in the CPATH, so we need to add "$ilmbase/include/OpenEXR/" to
                ;; the CPATH to satisfy the dependency on "half.h".
                (setenv "CPATH"
-                       (string-append (assoc-ref inputs "ilmbase")
-                                      "/include/OpenEXR"
-                                      ":" (or (getenv "CPATH") "")))
-               #t))))))
+                       (string-append
+                        (search-input-directory inputs "include/OpenEXR")
+                        ":" (or (getenv "CPATH") "")))))))))
     (inputs
      `(("boost" ,boost)
        ("jemalloc" ,jemalloc)
@@ -851,79 +855,63 @@ exception-handling library.")
     (license license:bsd-3)))
 
 (define-public lib2geom
-  ;; Use the latest master commit, as the 1.0 release suffer build problems.
-  (let ((revision "4")
-        (commit "b29d60e49a58f4e8069544b44863b1a623e4ee59"))
-    (package
-      (name "lib2geom")
-      (version (git-version "1.0" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://gitlab.com/inkscape/lib2geom.git")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "0xd8f3cgfnipdav4w8j54r7hzy9f3m7xk42ppcfhdjz2hriggyk6"))
-                (patches
-                 ;; Patch submitted to upstream (see:
-                 ;; https://gitlab.com/inkscape/lib2geom/-/merge_requests/32).
-                 (search-patches "lib2geom-fix-tests.patch"))
-                (modules '((guix build utils)))
-                (snippet
-                 '(begin
-                    ;; Fix py2geom module initialization (see:
-                    ;; https://gitlab.com/inkscape/lib2geom/merge_requests/18).
-                    (substitute* "src/py2geom/__init__.py"
-                      (("_py2geom") "py2geom._py2geom"))
-                    #t))))
-      (build-system cmake-build-system)
-      (arguments
-       `(#:imported-modules ((guix build python-build-system)
-                             ,@%cmake-build-system-modules)
-         #:configure-flags '("-D2GEOM_BUILD_SHARED=ON"
-                             "-D2GEOM_BOOST_PYTHON=ON"
-                             ;; Compiling the Cython bindings fail (see:
-                             ;; https://gitlab.com/inkscape/lib2geom/issues/21).
-                             "-D2GEOM_CYTHON_BINDINGS=OFF")
-         #:phases
-         (modify-phases %standard-phases
-           (add-after 'unpack 'patch-python-lib-install-path
-             (lambda* (#:key inputs outputs #:allow-other-keys)
-               (let* ((python-version (@ (guix build python-build-system)
-                                         python-version))
-                      (python-maj-min-version (python-version
-                                               (assoc-ref inputs "python")))
-                      (site-package (string-append
-                                     (assoc-ref outputs "out")
-                                     "/lib/python" python-maj-min-version
-                                     "/site-packages")))
-                 (substitute* '("src/cython/CMakeLists.txt"
-                                "src/py2geom/CMakeLists.txt")
-                   (("PYTHON_LIB_INSTALL \"[^\"]*\"")
-                    (format #f "PYTHON_LIB_INSTALL ~s" site-package))))
-               #t)))))
-      (native-inputs `(("python" ,python-wrapper)
-                       ("googletest" ,googletest)
-                       ("pkg-config" ,pkg-config)))
-      (inputs `(("cairo" ,cairo)
-                ("pycairo" ,python-pycairo)
-                ("double-conversion" ,double-conversion)
-                ("glib" ,glib)
-                ("gsl" ,gsl)))
-      (propagated-inputs
-       `(("boost" ,boost)))             ;referred to in 2geom/pathvector.h.
-      (home-page "https://gitlab.com/inkscape/lib2geom/")
-      (synopsis "C++ 2D graphics library")
-      (description "2geom is a C++ library of mathematics for paths, curves,
+  (package
+    (name "lib2geom")
+    (version "1.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.com/inkscape/lib2geom.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "03bx9k1m4bfhmx0ldsg0bks6i8h7fmvl5vbg6gmpq0bk0nkmpnmv"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:imported-modules ((guix build python-build-system)
+                           ,@%cmake-build-system-modules)
+       #:configure-flags '("-D2GEOM_BUILD_SHARED=ON"
+                           "-D2GEOM_BOOST_PYTHON=ON"
+                           ;; Compiling the Cython bindings fail (see:
+                           ;; https://gitlab.com/inkscape/lib2geom/issues/21).
+                           "-D2GEOM_CYTHON_BINDINGS=OFF")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-python-lib-install-path
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let* ((python-version (@ (guix build python-build-system)
+                                       python-version))
+                    (python-maj-min-version (python-version
+                                             (assoc-ref inputs "python")))
+                    (site-package (string-append
+                                   (assoc-ref outputs "out")
+                                   "/lib/python" python-maj-min-version
+                                   "/site-packages")))
+               (substitute* '("src/cython/CMakeLists.txt"
+                              "src/py2geom/CMakeLists.txt")
+                 (("PYTHON_LIB_INSTALL \"[^\"]*\"")
+                  (format #f "PYTHON_LIB_INSTALL ~s" site-package)))))))))
+    (native-inputs `(("python" ,python-wrapper)
+                     ("googletest" ,googletest)
+                     ("pkg-config" ,pkg-config)))
+    (inputs `(("cairo" ,cairo)
+              ("pycairo" ,python-pycairo)
+              ("double-conversion" ,double-conversion)
+              ("glib" ,glib)
+              ("gsl" ,gsl)))
+    (propagated-inputs
+     `(("boost" ,boost)))               ;referred to in 2geom/pathvector.h.
+    (home-page "https://gitlab.com/inkscape/lib2geom/")
+    (synopsis "C++ 2D graphics library")
+    (description "2geom is a C++ library of mathematics for paths, curves,
 and other geometric calculations.  Designed for vector graphics, it tackles
 Bézier curves, conic sections, paths, intersections, transformations, and
 basic geometries.")
-      ;; Because the library is linked with the GNU Scientific Library
-      ;; (GPLv3+), the combined work must be licensed as GPLv3+ (see:
-      ;; https://gitlab.com/inkscape/inkscape/issues/784).
-      (license license:gpl3+))))
+    ;; Because the library is linked with the GNU Scientific Library
+    ;; (GPLv3+), the combined work must be licensed as GPLv3+ (see:
+    ;; https://gitlab.com/inkscape/inkscape/issues/784).
+    (license license:gpl3+)))
 
 (define-public pstoedit
   (package
@@ -1196,7 +1184,7 @@ with strong support for multi-part, multi-channel use cases.")
 (define-public openimageio
   (package
     (name "openimageio")
-    (version "2.2.10.1")
+    (version "2.2.11.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -1205,7 +1193,7 @@ with strong support for multi-part, multi-channel use cases.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0wzh5n527l7ia1754cf9xmbvv4ya6hj34dy6cbq9xk9372h8gd9q"))))
+                "1i9r6vgz15aj1yzbf5a9lqhlyakjs793yrw5gw720l84lcyigad7"))))
     (build-system cmake-build-system)
     ;; FIXME: To run all tests successfully, test image sets from multiple
     ;; third party sources have to be present.  For details see
@@ -1218,6 +1206,7 @@ with strong support for multi-part, multi-channel use cases.")
     (inputs
      `(("boost" ,boost)
        ("fmt" ,fmt)
+       ("libheif" ,libheif)
        ("libpng" ,libpng)
        ("libjpeg" ,libjpeg-turbo)
        ("libtiff" ,libtiff)
@@ -1788,8 +1777,7 @@ requirements.")
                   (add-before 'check 'start-xorg-server
                     (lambda* (#:key inputs #:allow-other-keys)
                       ;; The test suite requires a running X server.
-                      (system (string-append (assoc-ref inputs "xorg-server")
-                                             "/bin/Xvfb :1 &"))
+                      (system "Xvfb :1 &")
                       (setenv "DISPLAY" ":1")
                       #t)))))
     (native-inputs