summary refs log tree commit diff
path: root/gnu/packages/graphviz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/graphviz.scm')
-rw-r--r--gnu/packages/graphviz.scm20
1 files changed, 15 insertions, 5 deletions
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index 52522af446..09f475bd90 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -36,16 +37,15 @@
 (define-public graphviz
   (package
     (name "graphviz")
-    (version "2.28.0")
+    (version "2.38.0")
     (source (origin
              (method url-fetch)
              (uri (string-append
                    "http://www.graphviz.org/pub/graphviz/ARCHIVE/graphviz-"
-                   version
-                   ".tar.gz"))
+                   version ".tar.gz"))
              (sha256
               (base32
-               "0xpwg99cd8sp0c6r8klsmc66h1pday64kmnr4v6f9jkqqmrpkank"))))
+               "17l5czpvv5ilmg17frg0w4qwf89jzh2aglm9fgx0l0aakn6j7al1"))))
     (build-system gnu-build-system)
     (arguments
      ;; FIXME: rtest/rtest.sh is a ksh script (!).  Add ksh as an input.
@@ -60,7 +60,16 @@
                    (substitute* "lib/gvc/Makefile"
                      (("am__append_5 *=.*")
                       "am_append_5 =\n")))
-                 %standard-phases)))
+                 (alist-cons-after
+                  'install 'move-docs
+                  (lambda* (#:key outputs #:allow-other-keys)
+                           (let ((out (assoc-ref outputs "out"))
+                                 (doc (assoc-ref outputs "doc")))
+                             (mkdir-p (string-append doc "/share/graphviz"))
+                             (rename-file (string-append out "/share/graphviz/doc")
+                                          (string-append doc "/share/graphviz/doc"))
+                             #t))
+                 %standard-phases))))
     (inputs
      `(("libXrender" ,libxrender)
        ("libX11" ,libx11)
@@ -77,6 +86,7 @@
     (native-inputs
      `(("bison" ,bison)
        ("pkg-config" ,pkg-config)))
+    (outputs '("out" "doc"))                      ; 5 MiB of html + pdfs
     (home-page "http://www.graphviz.org/")
     (synopsis "Graph visualization software")
     (description