summary refs log tree commit diff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 47d4c1808f..cc33c9f672 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -806,7 +806,8 @@ ever use this library.")
            ;; The CI test suite fails completely on powerpc-linux.
            ;; The name org.gnome.SessionManager was not provided by any .service
            ;; TODO: Wrap 'check phase with 'tests?'.
-           #$@(if (not (target-ppc32?))
+           #$@(if (not (or (target-ppc32?)
+                           (%current-target-system)))
                 #~((add-after 'install 'check
                      (lambda _
                        ;; xfconfd requires a writable HOME