summary refs log tree commit diff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index b0b6b16ff9..35859ee452 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -110,8 +110,13 @@
 
                       ;; The usual /bin/sh...
                       (substitute* "ice-9/popen.scm"
-                        (("/bin/sh") (which "sh")))
-                      #t)))))
+                        (("/bin/sh") (which "sh"))))))
+
+                ;; XXX: Several numerical tests and tests related to
+                ;; 'inet-pton' fail on glibc 2.33/GCC 10.  Disable them.
+                ;; TODO: Remove this package when its dependents no longer
+                ;; need it.
+                #:tests? #f))
 
    ;; When cross-compiling, a native version of Guile itself is needed.
    (native-inputs (if (%current-target-system)