summary refs log tree commit diff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm45
1 files changed, 11 insertions, 34 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index f179f293ea..30d2e2612c 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -906,7 +906,7 @@ for Guile\".")
 (define-public guile-json
   (package
     (name "guile-json")
-    (version "1.0.1")
+    (version "1.1.1")
     (home-page "https://github.com/aconchillo/guile-json")
     (source (origin
               (method url-fetch)
@@ -915,23 +915,11 @@ for Guile\".")
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "16155dv30rhagz6dwv7xc87l386i8v0f1kgydqa2ajr166fi9qhr"))
-              (modules '((guix build utils)))
-              (snippet
-               ;; Make sure everything goes under .../site/X.Y, like Guile's
-               ;; search paths expects.
-               '(begin
-                  (substitute* "configure.ac"
-                    (("GUILE_PROGS")
-                     (string-append "GUILE_PROGS\n"
-                                    "AC_SUBST([GUILE_EFFECTIVE_VERSION])\n")))
-                  (substitute* '("Makefile.am" "json/Makefile.am")
-                    (("moddir[[:blank:]]*=.*/share/guile/site" all)
-                     (string-append all "/@GUILE_EFFECTIVE_VERSION@")))
-                  #t))))
+                "12jqkn9qgwdlxbasy2n25a2a7apf30dww1nnxqfam5735k3jdngv"))))
     (build-system gnu-build-system)
     (native-inputs `(("autoconf" ,autoconf)
                      ("automake" ,automake)
+                     ("pkg-config" ,pkg-config)
                      ("guile" ,guile-2.2)))
     (inputs `(("guile" ,guile-2.2)))
     (synopsis "JSON module for Guile")
@@ -1241,31 +1229,20 @@ above command-line parameters.")
 (define-public guile-redis
   (package
     (name "guile-redis")
-    (version "0.1.0")
+    (version "1.0.0")
+    (home-page "https://github.com/aconchillo/guile-redis")
     (source (origin
               (method url-fetch)
-              (uri (string-append "mirror://savannah/guile-redis/guile-redis-"
-                                  version ".tar.gz"))
+              (uri (string-append home-page "/archive/" version ".tar.gz"))
               (sha256
                (base32
-                "0vx6if6b4r3kwx64vzbs6vpc0cpcr85x11w9vkzq27gw8n7isv56"))
-              (modules '((guix build utils)))
-              (snippet
-               ;; Make sure everything goes under .../site/X.Y, like Guile's
-               ;; search paths expects.
-               '(begin
-                  (substitute* "configure"
-                    (("ac_subst_vars='")
-                     "ac_subst_vars='GUILE_EFFECTIVE_VERSION\n"))
-                  (substitute* '("Makefile.in"
-                                 "redis/Makefile.in"
-                                 "redis/commands/Makefile.in")
-                    (("moddir =.*/share/guile/site" all)
-                     (string-append all "/@GUILE_EFFECTIVE_VERSION@")))
-                  #t))))
+                "1dp5fmqvma59pvp1nfpq6hqgbmjici8sd1y8llahl87fynw1dvr9"))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("guile" ,guile-2.2)))
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("pkg-config" ,pkg-config)
+       ("guile" ,guile-2.2)))
     (home-page "https://savannah.nongnu.org/projects/guile-redis/")
     (synopsis "Redis client library for Guile")
     (description "Guile-redis provides a Scheme interface to the Redis