summary refs log tree commit diff
path: root/gnu/packages/hardware.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/hardware.scm')
-rw-r--r--gnu/packages/hardware.scm80
1 files changed, 80 insertions, 0 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index ecbcca79b1..707a47fb4b 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -43,11 +43,13 @@
   #:use-module (gnu packages polkit)
   #:use-module (gnu packages protobuf)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages qt)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages web)
   #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg)
+  #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
   #:use-module (guix download)
   #:use-module (guix git-download)
@@ -100,6 +102,36 @@ calibrated, and restored when the calibration is applied.")
     (license (list license:bsd-3        ; FindDDCUtil.cmake
                    license:gpl2+))))    ; everything else
 
+(define-public ddcui
+  (package
+    (name "ddcui")
+    (version "0.1.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/rockowitz/ddcui")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0myma1zw6dlygv3xbin662d91zcnwss10syf12q2fppkrd8qdgqf"))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:tests? #f))                    ; No test suite
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("qttools" ,qttools)))
+    (inputs
+     `(("ddcutil" ,ddcutil)
+       ("glib" ,glib)
+       ("qtbase" ,qtbase-5)))
+    (home-page "https://www.ddcutil.com/")
+    (synopsis "Graphical user interface for ddcutil")
+    (description "ddcui is a graphical user interface for ddcutil, implemented
+using Qt.  It provide a dynamic way to inspect and configure external monitors
+through the Display Data Channel Command Interface (@dfn{DDC/CI}) protocol.")
+    (license (list license:gpl2+))))
+
 (define-public edid-decode
   (let ((commit "74b64180d67bb009d8d9ea1b6f18ad41aaa16396") ; 2020-04-22
         (revision "1"))
@@ -137,6 +169,54 @@ calibrated, and restored when the calibration is applied.")
 human-readable format and checks if it conforms to the standards.")
       (license license:expat))))
 
+(define-public i7z
+  (let ((revision "0")
+        (commit "1a41ff13db747e962456ddbb5ccb2b7fc43ca0cb"))
+    (package
+      (name "i7z")
+      (version (git-version "0.28" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/afontenot/i7z")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0jxm63a8y1mfl1sa4mzzfs3bgnym6achj1yc0jglmp05xal16lm1"))
+         (modules '((guix build utils)))
+         (snippet
+          '(begin
+             (for-each delete-file-recursively
+                       (list "src/GUI"
+                             "src/perfmon-i7z"
+                             "scripts"))))))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:make-flags
+         (list (string-append "prefix=" (assoc-ref %outputs "out"))
+               (string-append "CC=" ,(cc-for-target)))
+         #:tests? #f                    ; no test suite
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'configure))))       ; no configure script
+      (inputs
+       `(("ncurses" ,ncurses)))
+      (home-page "https://github.com/afontenot/i7z")
+      (synopsis "Thermal and C-state reporting on older Intel Core CPUs")
+      (description
+       "The @command{i7z} utility accurately measures the current frequency
+and temperature of older Intel Core (i3, i5, and i7) processors including the
+Nehalem, Sandy Bridge, and Ivy Bridge generations.  Reliable support for newer
+CPUs is not guaranteed, as this package has not seen significant development
+since 2013.
+
+If your processor is supported, you'll get detailed reports on Turbo Boost and
+clock multipliers, core voltage, and time spent in different C-states.  This
+information can be viewed in real time and/or logged to a file.")
+      (supported-systems (list "x86_64-linux"))
+      (license license:gpl2))))
+
 (define-public libsmbios
   (package
     (name "libsmbios")