summary refs log tree commit diff
path: root/gnu/packages/haskell-check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/haskell-check.scm')
-rw-r--r--gnu/packages/haskell-check.scm52
1 files changed, 51 insertions, 1 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index df7a667623..a200c1b60c 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -7,7 +7,7 @@
 ;;; Copyright © 2016 David Craven <david@craven.ch>
 ;;; Copyright © 2017 Danny Milosavljevic <dannym@scratchpost.org>
 ;;; Copyright © 2017 rsiddharth <s@ricketyspace.net>
-;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Tonton <tonton@riseup.net>
 ;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2019 Timothy Sample <samplet@ngyro.com>
@@ -515,6 +515,33 @@ hold in a large number of randomly generated cases.  Specifications are
 expressed in Haskell, using combinators defined in the QuickCheck library.")
     (license license:bsd-3)))
 
+(define-public ghc-quickcheck-assertions
+  (package
+    (name "ghc-quickcheck-assertions")
+    (version "0.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/"
+                           "quickcheck-assertions/"
+                           "quickcheck-assertions-" version ".tar.gz"))
+       (sha256
+        (base32 "1kyam4cy7qmnizjwjm8jamq43w7f0fs6ljfplwj0ib6wi2kjh0wv"))))
+    (build-system haskell-build-system)
+    (native-inputs
+     `(("ghc-hspec" ,ghc-hspec)))
+    (inputs
+     `(("ghc-ieee754" ,ghc-ieee754)
+       ("ghc-pretty-show" ,ghc-pretty-show)
+       ("ghc-quickcheck" ,ghc-quickcheck)))
+    (home-page "https://github.com/s9gf4ult/quickcheck-assertions")
+    (synopsis "HUnit-like assertions for QuickCheck")
+    (description
+     "This Haskell library provides convenient assertions with pretty-printed
+failure messages for QuickCheck properties, that are similar to those of
+HUnit.")
+    (license license:lgpl3)))
+
 (define-public ghc-test-framework
   (package
     (name "ghc-test-framework")
@@ -611,6 +638,29 @@ reporting and test statistics output.")
 package.")
     (license license:bsd-3)))
 
+(define-public ghc-test-framework-smallcheck
+  (package
+    (name "ghc-test-framework-smallcheck")
+    (version "0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/"
+                           "test-framework-smallcheck/"
+                           "test-framework-smallcheck-" version ".tar.gz"))
+       (sha256
+        (base32 "1xpgpk1gp4w7w46b4rhj80fa0bcyz8asj2dcjb5x1c37b7rw90b0"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-smallcheck" ,ghc-smallcheck)
+       ("ghc-test-framework" ,ghc-test-framework)))
+    (home-page "https://github.com/Bodigrim/smallcheck")
+    (synopsis "SmallCheck support for test-framework")
+    (description
+     "This package lets programmers use SmallCheck properties in Haskell's
+test-framework.  New projects should use ghc-tasty-smallcheck instead.")
+    (license license:bsd-3)))
+
 (define-public ghc-test-framework-th
   (package
     (name "ghc-test-framework-th")