summary refs log tree commit diff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm39
1 files changed, 34 insertions, 5 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 70a4eccce6..1c2538b45e 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -9,7 +9,7 @@
 ;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
 ;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@gmail.com>
 ;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
-;;; Copyright © 2020 Kyle Meyer <kyle@kyleam.com>
+;;; Copyright © 2020, 2022 Kyle Meyer <kyle@kyleam.com>
 ;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
 ;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;;
@@ -221,7 +221,7 @@ responses coming back.")
 (define-public ghc-http-client
   (package
     (name "ghc-http-client")
-    (version "0.6.4.1")
+    (version "0.7.11")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://hackage.haskell.org/package/"
@@ -229,7 +229,7 @@ responses coming back.")
                                   version ".tar.gz"))
               (sha256
                (base32
-                "1y12xfh6xvsfvyapbssmgrpjz025rmyccprbnmzhs0y1cmlz6hjp"))))
+                "12j7vkpkm2djws6ny7vm2324c7916d0iaf1mbvf4mfjxzy2w7imv"))))
     (build-system haskell-build-system)
     ;; Tests require access to the web.
     (arguments `(#:tests? #f))
@@ -242,6 +242,7 @@ responses coming back.")
            ghc-data-default-class
            ghc-exceptions
            ghc-http-types
+           ghc-iproute
            ghc-memory
            ghc-mime-types
            ghc-monad-control
@@ -262,7 +263,7 @@ for more user-friendly packages.")
 (define-public ghc-http-client-tls
   (package
     (name "ghc-http-client-tls")
-    (version "0.3.5.3")
+    (version "0.3.6.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://hackage.haskell.org/package/"
@@ -270,7 +271,7 @@ for more user-friendly packages.")
                                   version ".tar.gz"))
               (sha256
                (base32
-                "0qj3pcpgbsfsc4m52dz35khhl4hf1i0nmcpa445z82d9567vy6j7"))))
+                "03f8p9gxdzl6slyw1r6vpv2dqhsyjvbaawbjv75kaq0vlj3gz7xi"))))
     (build-system haskell-build-system)
     ;; Tests require Internet access
     (arguments `(#:tests? #f))
@@ -291,6 +292,34 @@ connection and TLS libraries.  It is intended for use by higher-level
 libraries, such as http-conduit.")
     (license license:expat)))
 
+(define-public ghc-http-client-restricted
+  (package
+    (name "ghc-http-client-restricted")
+    (version "0.0.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "http-client-restricted" version))
+       (sha256
+        (base32 "1vfm9qc3zr0rmq2ddgyg13i67020cdk8xqhyzfc2zcn1km2p6r85"))))
+    (build-system haskell-build-system)
+    (inputs
+     (list ghc-http-client
+           ghc-http-client-tls
+           ghc-connection
+           ghc-data-default
+           ghc-network
+           ghc-network-bsd
+           ghc-utf8-string))
+    (home-page "http://hackage.haskell.org/package/http-client-restricted")
+    (synopsis "Restrict the servers used by http-client")
+    (description
+     "This library makes it possible to restrict the HTTP servers that can be
+used by the @code{http-client} and @code{http-client-tls} libraries.  This is
+useful when a security policy needs to, e.g., prevent connections to HTTP
+servers on localhost or only allow connections to a specific server.")
+    (license license:expat)))
+
 (define-public ghc-http-date
   (package
     (name "ghc-http-date")