summary refs log tree commit diff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 254301e6c8..82c7109316 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -116,8 +116,7 @@
                   (guix build rpath)
                   (srfi srfi-26)
                   (srfi srfi-1))
-       #:imported-modules ((guix build gnu-build-system)
-                           (guix build utils)
+       #:imported-modules (,@%gnu-build-system-modules
                            (guix build rpath))
        #:configure-flags
        (list
@@ -799,7 +798,7 @@ mutable and immutable), with a powerful loop optimisation framework.")
      `(#:tests? #f  ; FIXME: currently missing libraries used for tests.
        #:phases
        (modify-phases %standard-phases
-         (add-before configure set-sh
+         (add-before 'configure 'set-sh
                      (lambda _ (setenv "CONFIG_SHELL" "sh"))))))
     (home-page "https://github.com/haskell/network")
     (synopsis "Low-level networking interface")