summary refs log tree commit diff
path: root/gnu/packages/haxe.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/haxe.scm')
-rw-r--r--gnu/packages/haxe.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/haxe.scm b/gnu/packages/haxe.scm
index dbe8b2c19e..e4ed5f6792 100644
--- a/gnu/packages/haxe.scm
+++ b/gnu/packages/haxe.scm
@@ -66,7 +66,8 @@
         (base32 "1xgw646pghsjjbzd8qlaq17vq96swlrazpivrvyrhdj36vb3sci3"))))
     (build-system cmake-build-system)
     (arguments
-     (list #:phases
+     (list #:disallowed-references (list httpd)
+           #:phases
            #~(modify-phases %standard-phases
                (add-after 'unpack 'prefix
                  (lambda _
@@ -76,7 +77,6 @@
     (inputs (list apr
                   apr-util
                   gtk+-2
-                  httpd
                   libgc
                   mbedtls-apache
                   mysql
@@ -84,7 +84,9 @@
                   pcre
                   sqlite
                   zlib))
-    (native-inputs (list git pkg-config)) ; git for source_archive and applying patch
+    (native-inputs (list httpd
+                         git ; git for source_archive and applying patch
+                         pkg-config))
     (home-page "https://nekovm.org/")
     (synopsis "High-level dynamically typed programming language and virtual
 machine")