summary refs log tree commit diff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 80101bb463..3d2a37a1e2 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -133,7 +133,7 @@ communication.")
 
 (define-public hurd-headers
   (let ((revision "3")
-        (commit "v0.9.git20230520"))
+        (commit "v0.9.git20231217"))
     (package
       (name "hurd-headers")
       (version (string-drop commit 1))
@@ -144,7 +144,7 @@ communication.")
                       (commit commit)))
                 (sha256
                  (base32
-                  "1m0lgk0741f3scib87130w1spc598zbz7gcc946wi7mg97h8d53m"))
+                  "1d138kzhil6s5gf9di8grpz1iziakyfv037wkc8s7qyd61imm31d"))
                 (file-name (git-file-name name version))))
       (build-system gnu-build-system)
       (native-inputs
@@ -181,6 +181,7 @@ communication.")
                              "ac_cv_func__hurd_exec_paths=no"
                              "ac_cv_func__hurd_libc_proc_init=no"
                              "ac_cv_func_file_futimens=no"
+                             "ac_cv_func_file_utimens=no"
                              "ac_cv_lib_acpica_acpi_init=no")
 
          #:tests? #f))
@@ -316,8 +317,7 @@ Hurd-minimal package which are needed for both glibc and GCC.")
     (name "hurd")
     (source (origin
               (inherit (package-source hurd-headers))
-              (patches (search-patches "hurd-fix-rumpdisk-build.patch"
-                                       "hurd-rumpdisk-no-hd.patch"))))
+              (patches (search-patches "hurd-rumpdisk-no-hd.patch"))))
     (version (package-version hurd-headers))
     (arguments
      `(#:tests? #f                      ;no "check" target