summary refs log tree commit diff
path: root/gnu/packages/icu4c.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/icu4c.scm')
-rw-r--r--gnu/packages/icu4c.scm26
1 files changed, 11 insertions, 15 deletions
diff --git a/gnu/packages/icu4c.scm b/gnu/packages/icu4c.scm
index aea5d2fae5..45dcfe2466 100644
--- a/gnu/packages/icu4c.scm
+++ b/gnu/packages/icu4c.scm
@@ -51,21 +51,17 @@
                           (guix build utils)
                           (guix build rpath))
       #:phases
-      (alist-replace
-       'unpack
-       (lambda* (#:key source #:allow-other-keys)
-        (and (zero? (system* "tar" "xvf" source))
-             (chdir "icu/source")))
-       (alist-replace
-        'configure
-        (lambda* (#:key #:allow-other-keys #:rest args)
-         (let ((configure (assoc-ref %standard-phases 'configure)))
-           ;; patch out two occurrences of /bin/sh from configure script
-           ;; that might have disappeared in a release later than 52.1
-           (substitute* "configure"
-             (("`/bin/sh")
-             (string-append "`" (which "bash"))))
-           (apply configure args)))
+      (alist-cons-after
+       'unpack 'chdir-to-source
+       (lambda _ (chdir "source"))
+       (alist-cons-before
+        'configure 'patch-configure
+        (lambda _
+          ;; patch out two occurrences of /bin/sh from configure script
+          ;; that might have disappeared in a release later than 52.1
+          (substitute* "configure"
+            (("`/bin/sh")
+             (string-append "`" (which "bash")))))
        (alist-cons-after
         'strip 'add-lib-to-runpath
         (lambda* (#:key outputs #:allow-other-keys)